[C++ 二叉树的构建与遍历] 数据结构实验之二叉树二:遍历二叉树

思考:
1. 第一次做二叉树的题,感觉理解了并不会太难,代码不多主要理解二叉树的思路
2. 在别的博客上看的的代码,踩了一下i++的坑,现在明白不少

参考博客
1. http://blog.csdn.net/karldoenitz/article/details/8180297
2. http://blog.csdn.net/hang__xiu2016acm/article/details/52224202

题目
数据结构实验之二叉树二:遍历二叉树
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic Discuss
Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。
Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

Example Input

abc,,de,g,,f,,,
Example Output

cbegdfa
cgefdba

code

#include <iostream>
using namespace std;

typedef struct BiTNode
{
    char data;
    struct BiTNode *lchild, *rchild; //左右孩子指针
}BiTNode,*BiTree;

char s[50];
int i;

int CreateBiTree(BiTree &T)  //preorder build BiTree
{
    if(s[i++]==',') T=NULL;
    else
    {
        T=new BiTNode;
        if(!T) return 0;
        T->data=s[i-1];
        CreateBiTree(T->lchild);
        CreateBiTree(T->rchild);
    }

    return 1;
}

void inorder(BiTree &T)//inorder print
{
    if(T) //node !== NULL
    {
        inorder(T->lchild);
        cout << T->data;
        inorder(T->rchild);
    }
}

void postorder(BiTree &T) //post printe
{
    if(T)
    {
        postorder(T->lchild);
        postorder(T->rchild);
        cout << T->data;
    }
}

int main()
{
    BiTree T;
    while(cin >> s) //非空
    {
        i=0;
        CreateBiTree(T);//生成二叉树
        inorder(T);//中序遍历
        cout << endl;
        postorder(T);//后序遍历
        cout << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值