HDU 1312 Red and Black DFS入门经典例题

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

这两天做的第四道DFS题了,,这题很水,但因为我在做题时的粗心改了段时间才改出来

错误一:将x方向的变量和y方向的变量混了,导致坐标都存错了

错误二:将全局变量作为参数传入了DFS函数,导致每回一次初始状态的DFS函数的调用累加起来的变量瞬间归零。

错误三:储存点移动方向的数组名起错了,与某个库中函数名重复了。

贴代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define maxn 25
using namespace std;

int m, n, idex[maxn][maxn], nums;
char field[maxn][maxn];
int nextj[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};

void DFS(int x, int y)
{
    if(x < 0|| y < 0|| x >= n|| y >= m) return;
    if(field[x][y] == '#' || idex[x][y] != 0) return;
    nums++;
    idex[x][y] = 1;
    int xx, yy;
    for(int i = 0; i < 4; i++)
    {
        xx = x + nextj[i][0], yy = y + nextj[i][1];
        DFS(xx, yy);
    }
}

int main()
{
    while(scanf("%d %d", &m, &n)&& m)
    {
        memset(idex, 0, sizeof(idex));
        int x, y;
        nums = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                cin >> field[i][j];
                if(field[i][j] == '@')
                {
                    x = i, y = j;
                }
            }
        }
        DFS(x, y);
        cout << nums << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值