HDOJ_1720_A+B Coming

题目:Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^

Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.

Output
Output A+B in decimal number in one line.

Sample Input

1 9
A B
a b

Sample Output

10
21
21


要注意的点:

1.hexadecimal number 十六进制数,c语言中的按格式输入中提供了输入十六进制数的办法。

scanf("%x",&i);//按十六进制数输入i;
printf("%d",i);//按十进制输出结果;

2.Input terminates by EOF.当是文件结尾时结束输入。

EOF=END OF FILE;

可以通过while (scanf(“%x %x”,&a,&b)!=EOF) 实现
3. in decimal number .输出为十进制数字。


代码如下:

#include <iostream>
using namespace std;
int main(){
    int a,b;
    while(scanf("%x %x",&a,&b)!=EOF){
        printf("%d\n",a+b);
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值