PAT for Java:03-PAT判断正确

题目源地址:https://pintia.cn/problem-sets/994805260223102976/problems/type/7

PAT判断正确:

“答案正确”是自动判题系统给出的最令人欢喜的回复。本题属于 PAT 的“答案正确”大派送 —— 只要读入的字符串满足下列条件,系统就输出“答案正确”,否则输出“答案错误”。

得到“答案正确”的条件是:

    (1)字符串中必须仅有 P、 A、 T这三种字符,不可以包含其它字符;
    (2)任意形如 xPATx 的字符串都可以获得“答案正确”,其中 x 或者是空字符串,或者是仅由字母 A 组成的字符串;
    (3)如果 aPbTc 是正确的,那么 aPbATca 也是正确的,其中 a、 b、 c 均或者是空字符串,或者是仅由字母 A 组成的字符串。

现在就请你为 PAT 写一个自动裁判程序,判定哪些字符串是可以获得“答案正确”的。

输入格式:
每个测试输入包含 1 个测试用例。第 1 行给出一个正整数 n (<10),是需要检测的字符串个数。接下来每个字符串占一行,字符串长度不超过 100,且不包含空格。

输出格式:
每个字符串的检测结果占一行,如果该字符串可以获得“答案正确”,则输出 YES,否则输出 NO。

输入样例:
8
PAT
PAAT
AAPATAA
AAPAATAAAA
xPATx
PT
Whatever
APAAATAA
输出样例:
YES
YES
YES
YES
NO
NO
NO
NO

代码:

import java.util.Scanner;

public class PatJudge {

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int length = Integer.parseInt(sc.nextLine());
		String temp[] = new String[length];
		for (int i = 0; i < temp.length; i++) {
			temp[i] = sc.nextLine();
		}
		for (int i = 0; i < temp.length; i++) {
			boolean isPAT = false;
			int pCounts = 0, aCounts = 0, tCounts = 0, otherCounts = 0;
			for (int j = 0; j < temp[i].length(); j++) {
				if ("p".equalsIgnoreCase(temp[i].charAt(j) + "")) {
					pCounts++;
					continue;
				} else if ("a".equalsIgnoreCase(temp[i].charAt(j) + "")) {
					aCounts++;
					continue;
				} else if ("t".equalsIgnoreCase(temp[i].charAt(j) + "")) {
					tCounts++;
					continue;
				} else {
					otherCounts++;
					continue;
				}
			}
			if (pCounts == 1 && aCounts > 0 && tCounts == 1 && otherCounts == 0 && length < 10
					&& temp[i].length() <= 100) {
				int lP = 0;
//				    int lA = 0;
				int lT = 0;
				for (int k = 0; k < temp[i].length(); k++) {
					if ("p".equalsIgnoreCase(temp[i].charAt(k) + "")) {
						lP = k;
					}
//					if ("a".equalsIgnoreCase(temp[i].charAt(k) + "")) {
//						lA = k;
//					}
					if ("t".equalsIgnoreCase(temp[i].charAt(k) + "")) {
						lT = k;
					}
				}
//					if (lP == -1 || lA == -1 || lT == -1) {
//						isPAT = false;
//					}
				if (lP * (lT - lP - 1) == (temp[i].length() - lT - 1)) {
					isPAT = true;
				}
			}
			if (isPAT) {
				System.out.println("YES");
				isPAT = false;
			} else {
				System.out.println("NO");
			}
		}
		sc.close();
	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值