2^x mod n = 1

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input

One positive integer on each line, the value of n.

Output

If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input

 
 
2 5

Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1

解析:

import java.util.*;

/**
 * 此题容易超时,所以在每次循环中都要将次方值模以n。
 */
public class 二的x次方_mod_n_等于_1 {

	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		while (input.hasNext()) {

			int n = input.nextInt();

			if (n % 2 == 0 || n == 1) {
				System.out.println("2^? mod " + n + " = 1");
				continue;
			}

			int s = 1;
			for (int i = 1; i > 0; i++) {

				s = s * 2;
				if (s % n == 1) {

					System.out.println("2^" + i + " mod " + n + " = 1");
					break;
				}
				s = s % n;// 这一步可以如果不写,就会超时
			}

		}

	}

}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值