数据结构——集合
用来表示集合信息,用以实现如确定某个集合含有哪些元素、判断两个元素是否存在在同一集合中 、求集合中元素个数等问题。
方法:用一棵树来表示一个集合,判断是否在一个集合中,只需判断是否在一棵树上。
定义数组Tree[]来表示双亲结点编号,若该结点已经是根节点,则保存为-1
#define N 1000
int Tree[N];
//初始化所有节点的树根为-1,即为独立节点,注意循环的开始和结束i,n为结点个数
for (i = 1; i <= n; i++) {
Tree[i] = -1;
}
查找结点的根函数
int findroot(int x) {
if (Tree[x] == -1) return x;
else {
int t = findroot(Tree[x]);
Tree[x] = t;
return t;
}
}
例一 九度1012 畅通工程
-
题目描述:
-
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
-
输入:
-
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
-
输出:
-
对每个测试用例,在1行里输出最少还需要建设的道路数目。
-
样例输入:
-
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
-
样例输出:
-
1 0 2 998
#include<stdio.h>
using namespace std;
#define N 1000
int Tree[N];
//找到该节点的树根
int findroot(int x) {
if (Tree[x] == -1) return x;
else {
int t = findroot(Tree[x]);
Tree[x] = t;
return t;
}
}
int main() {
int n, m;
while (scanf("%d %d" ,&n, &m)!=EOF) {
if (n == 0) break;
int i, j;
int ans=0;
//初始化所有节点的树根为-1,即为独立节点,注意循环的开始和结束i
for (i = 1; i <= n; i++) {
Tree[i] = -1;
}
while (m--) {
int a, b;
scanf("%d %d", &a, &b);
a = findroot(a);
b = findroot(b);
if (a != b) { //如果两个节点的根节点不一样即不在同一棵集合树上,则合并
Tree[a] = b;
}
}
//统计根节点的个数,即一共有多少棵树
for (i = 1; i <= n; i++) {
if (Tree[i] == -1) {
ans++;
}
}
printf("%d\n", ans-1); //将这些树联通起来,需要ans-1条路径
}
return 0;
}
例二 九度1444 More is better
-
题目描述:
-
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
-
输入:
-
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
-
输出:
-
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
-
样例输入:
-
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
-
样例输出:
-
4 2
#include<stdio.h>
using namespace std;
#define N 10000001
int Tree[N];
int sum[N]; //用来表示每个树的节点数
int treeRoot(int x) {
if (Tree[x] == -1) return x;
else {
int t=treeRoot(Tree[x]);
Tree[x] = t;
return t;
}
}
int main() {
int n;
int i, j;
while (scanf("%d", &n) != EOF) {
int a, b;
int ans = 1;
//初始化根节点和每个根节点所在树的节点数
for (i = 1; i < N; i++) {
Tree[i] = -1;
sum[i] = 1;
}
while (n--) {
scanf("%d %d", &a, &b);
a = treeRoot(a);
b = treeRoot(b);
if (a != b) {
Tree[a] = b;
sum[b] += sum[a];
}
}
for (i = 1; i <= N; i++) {
if (sum[i] > ans) {
ans = sum[i];
}
}
printf("%d\n", ans);
}
}
练习 九度1109 连通图
题目描述:
给定一个无向图和其中的所有边,判断这个图是否所有顶点都是连通的。
输入:
每组数据的第一行是两个整数 n 和 m(0<=n<=1000)。n 表示图的顶点数目,m 表示图中边的数目。如果 n 为 0 表示输入结束。随后有
m 行数据,每行有两个值 x 和 y(0<x, y <=n),表示顶点 x 和 y 相连,顶点的编号从 1 开始计算。输入不保证这些边是否重复。
输出:
对于每组输入数据,如果所有顶点都是连通的,输出"YES",否则输出"NO"。
4 3
1 2
2 3
3 2
3 2
1 2
2 3
0 0
样例输出:
NO
YES
#include<stdio.h>
using namespace std;
#define N 1001
int Tree[N];
int treeRoot(int x) {
if (Tree[x] == -1) return x;
else {
int t=treeRoot(Tree[x]);
Tree[x] = t;
return t;
}
}
int main() {
int n, m;//分别表示点的个数和边的个数
int i, j;
while (scanf("%d %d", &n, &m) != EOF) {
if (n == 0) break;
//初始化每个节点的根节点
for (i = 1; i <= n; i++) {
Tree[i] = -1;
}
int a, b;
while (m--) {
scanf("%d %d", &a, &b);
a = treeRoot(a);
b = treeRoot(b);
if (a != b) {
Tree[a] = b;
}
}
int sum=0;
for (i = 1; i <= n; i++) {
if (Tree[i] == -1) sum++;
}
if (sum == 1) printf("YES\n");
else printf("NO\n");
}
}