贪心poj练习

今天做了一个贪心练习的变形,感觉很不错,虽然自己调错误调了很久,但是全都是自己写出来的代码,感觉还是很开心的

POJ1328

该题将点坐标转化成线段,即以每个小岛为圆心,以d为半径做圆看与x轴的交点,每个线段利用贪心算法从左至右求解

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
struct Island {
	float startx; //岛屿与x轴的第一个交点
	float endx; //岛屿与x轴的第二个交点
	int x, y;
}island[1000];
bool cmp(Island a, Island b) {
	return a.endx < b.endx;
}
int main() {
	int n, d;//小岛数量和辐射范围
	int i, j;
	float len; //表示两个交点之间的长度
	int casenum = 0;
	while (scanf("%d %d", &n, &d) != EOF) {
		if (n == 0 && d == 0) break;
		int flag = 1;//标志是否能辐射到
		casenum++;
		for (i = 0; i < n; i++) {
			scanf("%d %d", &island[i].x, &island[i].y);
			if (island[i].y > d) { //如果没有交点,即无法辐射到
				flag = 0;
			}
			if (island[i].y == d) { //只有一个交点
				island[i].startx = island[i].endx = island[i].x;
			}
			if (island[i].y < d) { //有两个交点
				len = sqrt(1.0*d*d - island[i].y*island[i].y);
				island[i].startx = island[i].x - len;
				island[i].endx = island[i].x + len;
			}
		}
		//按照endx排序
		sort(island, island + n, cmp);
		//排好序之后比较后一个点的startx和前一个点的endx
		int ans = 1;
		float pos = island[0].endx;
		for (i = 1; i < n; i++) {
			if (pos < island[i].startx) {
				ans++;
				pos= island[i].endx;
			}
		}
		if (flag == 0) { printf("Case %d: -1\n", casenum); }
		else {
			printf("Case %d: %d\n", casenum,ans);
		}
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值