Corn Fields 状压DP

                                                                                                    Corn Fields

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10891 Accepted: 5705

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9
 

Hint

Number the squares as follows:
1 2 3
  4  
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题意:

给出一个M*N的矩阵,元素为0表示这个地方不能种玉米,为1表示这个地方能种玉米,现在规定所种的玉米不能相邻,即每行或者没列不能有相邻的玉米,问一共有多少种种植方法。


题解:状态压缩,动态规划

#include<stdio.h>
#include<string.h>
#define mod 100000000

int  dp[13][1<<13],f[15][15],checkr[1<<13];
int M,N;

int checkrow(int j){//判断同一行是否有相邻的 
	int t=0;
	while(t<N-1){
		if( (j & (1<<t)) && (j & (1<<(t+1))) ){ 
			return 0;
		}
	    t++;	
	}
	return 1;
} 

int check(int i,int j){//第i行状态j既满足同行不相邻,种玉米的地方都是可以种玉米区域 
	if(checkr[j]==0){
		return 0;
	}
	int t=0;
	while(t<N){
		if(((j & (1<<t))!=0) && (f[i][N-t-1]==0)){//检查是否有不可以种玉米的地方中了 
			return 0;
		} 
		t++;
	}
	return 1;
}

int compare(int i,int j,int k){//判断同列不相邻 
	if(dp[i-1][k]==0){
		return 0;
	}
	else{
		int t=0;
		while(t<N){
			if( (j & (1<<t)) && (k & (1<<t)) ){
				return 0;
			}
			t++;
		}
	}
	return 1;
}

int main(){
	int i,j,k,s,ans=0;
	memset(dp,0,sizeof(dp));
	memset(f,0,sizeof(f));
	memset(checkr,0,sizeof(checkr));
	scanf("%d%d",&M,&N);
	for(i=0;i<M;i++){
		for(j=0;j<N;j++){
			scanf("%d",&f[i][j]);
		}
	}
	s=(1<<N)-1;
	for(j=0;j<=s;j++){//状态j既满足同行不相邻,种玉米的地方都是可以种玉米区域,后重复用到,保存下来 
		if(checkrow(j)==1){
			checkr[j]=1;
		}		
	}
   //第0行满足的状态 
	for(j=0;j<=s;j++){
		if(check(0,j)==1){
			dp[0][j]=1;
		}		
	}
	//核心算法,dp	
	for(i=1;i<M;i++){
		for(j=0;j<=s;j++){
			for(k=0;k<=s;k++){
				if( check(i,j)==1 && checkr[j]==1 && compare(i,j,k)==1){
					dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
				}
			} 
		}
	}	
	for(j=0;j<=s;j++){
		ans=(ans+dp[M-1][j])%mod;
	}
	printf("%d",ans); 
} 



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值