小白學JAVA-----P1008

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
-----------------------------------------------------------------------------------------

import java.util.Scanner;



public class Main {


public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int N=sc.nextInt();//要去几个楼层
if(N==0){
break;
}
int a[]=new int[N];//定义一个数组,把要去的楼层装在一个数组里
for(int i=0;i<N;i++){
a[i]=sc.nextInt();//输入每一个楼层
}

int t=0;
t=N*5;//在每一层都要停5秒
for(int i=0;i<N;i++){
if(i==0){
t=t+a[i]*6;
}else{
if(a[i]>a[i-1]){
t=t+(a[i]-a[i-1])*6;
}

if(a[i]<a[i-1]){
t=t+(a[i-1]-a[i])*4;
}
}

}
System.out.println(t);
}
}

}

英语不好的这道题难度很大 因为读不懂题目的意思,这道题意思是:刚才在第0层处于停滞状态,上一层楼需要6秒,下一层楼需要4秒,到指定楼层停5秒。例如

  
  
1 2 就是从0层开始上了两层就是2*6=12秒加上在0层停的5秒就是17秒 3 2 3 1 这里就是从0到2用了2*6=12秒加上从2到3的6秒加上从3到1的8秒加上每到一层停的5秒就是12+6+8+15=41秒
  
  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值