动态规划 数字三角形 poj1163

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51078 Accepted: 30942
Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output

30

题意:从顶点出发找到一条max值的路线 输出max值


题解:因为只能往左下或者右下走 所以只要

 int x = maxsum(i+1,j);
 int y = maxsum(i+1,j+1);
 maxsum1[i][j]=max(x,y)+d[i][j];
为了提高效率 可以使用一个数组记录下来之前算的结果 避免重复计算
#include <iomanip>
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<cmath>
#define maxn 105

using namespace std;
int d[maxn][maxn];
int n;
int maxsum1[maxn][maxn];
int maxsum(int i,int j)
{
    if(maxsum1[i][j]!=-1)
        return maxsum1[i][j];
    if(i==n)
        maxsum1[i][j]=d[i][j];
    else{
        int x = maxsum(i+1,j);
        int y = maxsum(i+1,j+1);
        maxsum1[i][j]=max(x,y)+d[i][j];
    }
    return maxsum1[i][j];
}

int main(){
    cin>>n;
    for(int i = 1;i<=n;i++){
        for(int j = 1;j<=i;j++){
            cin>>d[i][j];
            maxsum1[i][j]= -1;}}
    cout<<maxsum(1,1)<<endl;
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值