POJ2306 Lake Counting

1 篇文章 0 订阅
Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37065 Accepted: 18433

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3


题意:图中有多少个不同的连通块 比如左上角的算一个 左下角的算一个 右边的算一个 一共是3个


题解:dfs水题 hdu有题差不多的 符号换下就行了


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int maxn = 105;
char map[maxn][maxn];
int move[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int sum,m,n;
void dfs(int x, int y) {
	int tx;
	int ty;
	for (int i = 0; i<8; i++) {
		tx = x + move[i][0];
		ty = y + move[i][1];
		if (1 <= tx&&tx <= m && 1 <= ty&&ty <= n) {
			if (map[tx][ty] == 'W') {
				map[tx][ty] = '.';
				dfs(tx, ty);
			}
		}
	}
}
int main() {
	scanf("%d%d",&m,&n);
	sum=0;
	for (int i = 1; i<=m; i++) {
		for (int j = 1; j<=n; j++) {
			cin >> map[i][j];
		}
	}
	for (int i = 1; i<=m; i++) {
		for (int j = 1; j<=n; j++) {
			if (map[i][j] == 'W') {
				sum++;
				map[i][j] = '.';
				dfs(i,j);
			}
		}
	}
	cout << sum << endl;
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值