hdu 1063 高精度幂

Exponentiation

 

Time Limit: 2000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10469    Accepted Submission(s): 3058

 

 

Problem Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 

 

 

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

 

 

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

 

 

Sample Input

 

95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12

 

 

Sample Output

 

548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201

 

 

Source

East Central North America 1988

 

 

Recommend

PrincetonBoy   |   We have carefully selected several similar problems for you:  1250 1065 1829 1060 1209 

 

 

import java.math.BigDecimal;
import java.util.Scanner;

public class Main
{
    public static void main(String []args)
    {
        Scanner in =new Scanner(System.in);
        while (in.hasNext())
        {
            BigDecimal a = in.nextBigDecimal();
            int n = in.nextInt();

            //stripTrailingZeros去掉后缀0,toPlainString表示形式不带指数的字符串,然后用正则去掉小数点前的0
            System.out.println(a.pow(n).stripTrailingZeros().toPlainString().replaceAll("^(0.)","."));    

            //结果一样的
//            BigDecimal b = a;
//            for (int i = 1; i < n; i++)
//            {
//                a = a.multiply(b);
//            }
//            System.out.println(a);
        }

    }


}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值