顺序表应用1:多余元素删除之移位算法

顺序表应用1:多余元素删除之移位算法
Time Limit: 1000MS Memory Limit: 650KB
Submit Statistic
Problem Description

一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
2、本题的目标是熟悉顺序表的移位算法,因此题目必须要用元素的移位实现删除;
Input

第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。
Output

输出有n行,为每个顺序表删除多余元素后的结果
Example Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3
Example Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5
Hint

Author

#include<stdio.h>
#include<stdlib.h>
struct node{
    int data;
    struct node *next;
};

struct node *create(int n){
    struct node *head;
    struct node *q,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    q=head;
    for(int i=0;i<n;i++){
        p=(struct node *)malloc(sizeof(struct node));
        p->next=NULL;
        scanf("%d",&p->data);
        q->next=p;
        q=q->next;
    }
    return head;
}

int deleteo(struct node *head,int n){
    struct node *p,*q;
    struct node *o;
    p=head->next;
    for(int i=0;i<n;i++){
        q=p;
        int f=0;
        for(int j=i;j<n-1;j++){

            o=q->next; //printf("%d",o->data);
            if(p->data==o->data){

                q->next=o->next;

                free(o);
                f++;
            }else{
                q=q->next;
            }

        }
        p=p->next;
        n=n-f;
    }
    return n;
}

void show(struct node *head,int n){
    struct node *p;
    p=head->next;
    for(int i=0;i<n;i++){
        i<n-1?printf("%d ",p->data):printf("%d",p->data);
        p=p->next;
    }
    printf("\n");
}

int main(){

    int m;
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        int n;
        struct node *head;
        scanf("%d",&n);
        head=create(n);
        n=deleteo(head,n);
        show(head,n);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值