数据结构实验之查找一:二叉排序树

数据结构实验之查找一:二叉排序树
Time Limit: 400MS Memory Limit: 65536KB
Submit Statistic
Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。
Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。
Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出”Yes”,否则输出”No”。
Example Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0
Example Output

Yes
No
No
Hint

Author

#include <stdio.h>
#include <iostream>
#include <limits.h>
#include <stdlib.h>
#include <string.h>

typedef struct tree
{
    tree *left;
    tree *right;
    int data;
}tree;

void createTree(tree *&root,int data)
{
    if(root==NULL)
    {
        root = (tree *)malloc(sizeof(tree));
        root->data = data;
        root->left = root->right = NULL; 
    }
    else if(root->data>data) 
    {
        createTree(root->left,data);
    }
    else
    {
        createTree(root->right,data);
    }
}

void inorder(tree *root)
{
    if(root)
    {
        inorder(root->left);
        printf("%d ",root->data);
        inorder(root->right);
    }
}
int flag = 1;
void cmp(tree *root1,tree *root2)
{
    if(root1==NULL&&root2!=NULL||root1!=NULL&&root2==NULL)
    {
        flag = 0;
        return ;
    }
    else if(root1==NULL&&root2==NULL)
    {
        return ;
    }
    else if(root1->data!=root2->data)
    {
        flag = 0;
        return ;
    }

    else 
    {
        cmp(root1->left,root2->left);
        cmp(root2->right,root1->right);
    }
}

int main()
{
    int n,l;
    while(~scanf("%d",&n))
    {
        if(!n)
        {
            break;
        }
        scanf("%d",&l);
        tree *root1;
        root1 = NULL;
        for(int i = 0;i<n;i++)
        {
            int temp;
            scanf("%d",&temp);
            createTree(root1,temp);
        }
        while(l--)
        {
            flag = 1;
            tree *root2 = NULL;
            for(int i = 0;i<n;i++)
            {
                int temp;
                scanf("%d",&temp);
                createTree(root2,temp);
            }
            cmp(root1,root2);
            if(flag==1)
            {
                printf("Yes\n");
            }
            else
            {
                printf("No\n");
            }
        }
    }
    return 0;   
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值