1140. Look-and-say Sequence

3.18考试的时候没看明白题目意思,直接跳过了最简单的题目T-T

看懂了题目意思还是很简单的。

D!=1为例,第一个数是D。第二个数描述第一个数,一个D,写作D1。第三个数描述第二个数,一个D一个一,写作D1 11。第四个数描述第三个数,一个D三个一,写作D1 13。第五个数描述第四个数,一个D两个一一个三,写作D1 12 31。第六个数描述第五个数,一个D两个一一个二一个三一个一,写作D1 12 21 31 11。

总之就是连续的数字才放在一起统计。

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int D;
    int N;
    vector<int> num1;
    vector<int> num2;
    while(scanf("%d%d",&D,&N)!=EOF)
    {
        num1.clear();
        num2.clear();//num2来描述num1
        num1.push_back(D);
        for(int i=1;i<N;i++)
        {
            int len=num1.size();
            int numIdx=0;//表示读到num1的第几个位置了
            while(numIdx<len)
            {
                num2.push_back(num1[numIdx]);//把numIdx记录下来,一个新的要统计的数字
                num2.push_back(1);//初始计数器为1
                int num2Size=num2.size();
                //循环看num1[numIdx+1]是不熟等于num1[numIdx]
                while(numIdx<len-1&&num1[numIdx]==num1[numIdx+1]) {
                    num2[num2Size - 1]++;//是的话计数器++
                    numIdx++;//下标后移
                }
                numIdx++;//不是的话下标去一个新的不同与之前的数字
            }
            num1.clear();
            num1=num2;
            num2.clear();
        }
        vector<int>::iterator it;
        for(it=num1.begin();it<num1.end();it++)
        {
            cout<<*it;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值