大侦探福尔摩斯接到一张奇怪的字条:我们约会吧! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm
。大侦探很快就明白了,字条上奇怪的乱码实际上就是约会的时间星期四 14:04
,因为前面两字符串中第 1 对相同的大写英文字母(大小写有区分)是第 4 个字母 D
,代表星期四;第 2 对相同的字符是 E
,那是第 5 个英文字母,代表一天里的第 14 个钟头(于是一天的 0 点到 23 点由数字 0 到 9、以及大写字母 A
到 N
表示);后面两字符串第 1 对相同的英文字母 s
出现在第 4 个位置(从 0 开始计数)上,代表第 4 分钟。现给定两对字符串,请帮助福尔摩斯解码得到约会的时间。
输入格式:
输入在 4 行中分别给出 4 个非空、不包含空格、且长度不超过 60 的字符串。
输出格式:
在一行中输出约会的时间,格式为 DAY HH:MM
,其中 DAY
是某星期的 3 字符缩写,即 MON
表示星期一,TUE
表示星期二,WED
表示星期三,THU
表示星期四,FRI
表示星期五,SAT
表示星期六,SUN
表示星期日。题目输入保证每个测试存在唯一解。
输入样例:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
输出样例:
THU 14:04
第一次代码:
#include<iostream>
using namespace std;
int main()
{
string Day[8]={"MON","TUE","WED","THU","FRI","SAT","SUN"};
string Firstr,Sedstr,Thirstr,Fourstr;
int nowDay=0,nowtime=0,nowmintime=0;
int count=0;
cin>>Firstr>>Sedstr>>Thirstr>>Fourstr;
for(int i=0;i<int(Firstr.length());i++)
{
if(Firstr[i]==Sedstr[i])
{
if(Firstr[i]>='A'&&Firstr[i]<='Z'&&count==0)
{
nowDay=Firstr[i]-'A';
count++;
continue;
}
if(((Firstr[i]>='0'&&Firstr[i]<='9')||(Firstr[i]>='A'&&Firstr[i]<='N'))&&count==1)
{
if(Firstr[i]>='0'&&Firstr[i]<='9')
nowtime=Firstr[i]-'0';
if(Firstr[i]>='A'&&Firstr[i]<='N')
nowtime=Firstr[i]-'A'+10;
break;
}
}
}
for(int i=0;i<int(Thirstr.length());i++)
{
if(Thirstr[i]==Fourstr[i]&&((Thirstr[i]>=65&&Thirstr[i]<=90)||(Thirstr[i]>=97&&Thirstr[i]<=122)))
{
nowmintime=i;
}
}
if(nowmintime<10)
{
cout<<Day[nowDay]<<" "<<nowtime<<":0"<<nowmintime;
}
else
{
cout<<Day[nowDay]<<" "<<nowtime<<":"<<nowmintime;
}
return 0;
}
第二次代码
#include<iostream>
#include<string>
using namespace std;
int comparetime(string a,string b)
{
for(int i=0;i<int(a.length());i++)
if(a[i]==b[i]&&((a[i]>='A'&&a[i]<='Z')||(a[i]>='a'&&a[i]<='z')))
return i;
return 0;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("1.txt","r",stdin);
#endif
string a,b,c,d;
cin>>a>>b>>c>>d;
char week[7][4]={"MON","TUE","WED","THU","FRI","SAT","SUN"};
string time="0123456789ABCDEFGHIJKLMN";
char c1,c2;
int n1;
int count=0,count1=0;
for(int i=0;i<int(a.length());i++)
{
if(a[i]==b[i]&&count==0&&(a[i]>='A')&&(a[i]<='G'))
{
c1=a[i];
count++;
continue;
}
if(a[i]==b[i]&&count==1&&(((a[i]>='A')&&(a[i]<='N'))||((a[i]-'0'>=0)&&(a[i]-'0'<10))))
{
c2=a[i];
break;
}
}
n1=comparetime(c,d);
cout<<week[c1-'A']<<" ";
for(int i=0;i<int(time.length());i++)
{
if(c2==time[i]&&c2-'0'>=0&&c2-'0'<10)
{
cout<<"0"<<c2-'0'<<":";
}
else if(c2==time[i])
cout<<i<<":";
}
if(n1<10)
cout<<"0"<<n1;
else
cout<<n1;
return 0;
}