小白算法练习 二分图染色 dfs 选择四种状态表示

 

Wrestling Match

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2346    Accepted Submission(s): 853

 

 

Problem Description

Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".

 

 

Input

Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.

 

 

Output

If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".

 

 

Sample Input

 

5 4 0 0 1 3 1 4 3 5 4 5 5 4 1 0 1 3 1 4 3 5 4 5 2

 

 

Sample Output

 

NO YES

 

 

 

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<vector>
#define Max 100008
using namespace std;
vector<int>vec[Max];
int color[Max]={0};
int pre[Max]={0};
void init(int a,int b){
    vec[a].push_back(b);
    vec[b].push_back(a);
    color[a]=0;
    color[b]=0;
}
bool dfs(int i,int c){
    color[i]=c;
    for(int k=0;k<vec[i].size();k++)
    {
        if(color[vec[i][k]]==c) return false;
        if(color[vec[i][k]]==0 && dfs(vec[i][k],-c)==false ) return false;
    }
    return true;
}
int main(){
    
 
    
    int v,u;//点 , 边
    int good,bad;//good 1   bad -1
while(    scanf("%d%d%d%d",&v,&u,&good,&bad)!=EOF){
    //clear
    memset(color,0,sizeof(color));
    memset(pre,0,sizeof(pre));
    for(int i=0;i<Max;i++)
    {
        vec[i].clear();
        color[i]=-5;
    }
    //input
    for(int i=1;i<=u;i++)
    {
        int a,b;scanf("%d%d",&a,&b);
        init(a,b);    
    } 
    for(int i=1;i<=good;i++)
    {
        int a;scanf("%d",&a);
        color[a]=1;
        pre[a]=-1;
    }
    for(int i=1;i<=bad;i++)
    {
        int a;scanf("%d",&a);
        color[a]=-1;
        pre[a]=-1;
    }    
    int flag=0;
    //binary_ 
    for(int i=1;i<=v;i++)
    {
        if(color[i]==1 && pre[i]==-1)
        {
            if(dfs(i,1)==0)
            {
                flag=1;
            }
        }    
        else if(color[i]==-1 && pre[i]==-1)
        {
            if(dfs(i,-1)==0)
            {
                flag=1;
            }
        }
    } 
    for(int i=1;i<=v;i++)
    {
        if(color[i]==0)
        {
            if(dfs(i,1)==0)
            {
                flag=1;
            }
        }    
    }  
    for(int i=1;i<=v;i++)
    {
        if(color[i]==-5)
        {
            flag=1;
        }
    }
 
    if(flag==1)
    {
        cout<<"NO"<<endl;
    }
    else
    {
        cout<<"YES"<<endl;
    }
}
    return 0;
} 

选择 四种状态 来表示染色情况 (1 已知染成good )(-1 已知染成bad)(没有打擂台【摔跤】)(打过擂台但是不知道是good or bad);如果你只用三种情况表示的话是不太方便染色的,因为这里一共有四种情况,当然我是一个小白,大牛是可以做出来的,但是我们做题目之前,先把情况都列举出来,再用变量表示状态是不会有错的。 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值