二分搜索

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. Ay foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values ofx,y, andc.

Output

For each case, output the case number and the width of the street in feet. Errors less than10-6 will be ignored.

Sample Input

4

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

Sample Output

Case 1: 26.0328775442

Case 2: 6.99999923

Case 3: 8

Case 4: 9.797958971


学会构造表达式,输入在其左端,结果在右端需为定值(代码中与mid比较的 1 便是定值)


#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
double c,y,x,a;
double f(double a)
{
 return c/sqrt(y*y-a*a)+c/sqrt(x*x-a*a);
}
int main()
{
 int t,p=0;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%lf %lf %lf",&x,&y,&c);
  double left=0.0,right=min(x,y),mid,k;//学会使用c++,min函数可以直接调用
  while(right-left>=0.0000000001)//精度
  {
   mid=(left+right)/2;
   if(f(mid)==1)
   {
    break;
   }
   else if(f(mid)>1)
   {
    right=mid;//right=mid-0.0000001;
   }
   else
       left=mid;//left=mid+0.0000001;
  }
  printf("Case %d: %lf\n",++p,mid);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值