The Unique MST (次小生成树)

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!

题意:如果只有一个最小生成树则输出总权值,若有多个则Not Unique!;(找出最小生成树的个数类似)

思路:和上篇博客差不多,套用Kruskal,只不过套用了两次(这种思路好像不太高效,续更···)

第一遍时找出最小生成树并标记用过的边,然后第二遍中找是否有新的边加入(ans的真假)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pre1[11000],pre2[11000];
struct node
{
	int a;
	int b;
	int c;
	int d;
}s[50100];
bool cmp(node x,node y)
{
	if(x.c!=y.c)
		return x.c<y.c;
	return x.d<y.d;
}
int main()
{
	int m,n,r1,r2,i,t;
	scanf("%d",&t);
	while(t--)
	{	
		memset(s,-1,sizeof(s));
		scanf("%d %d",&m,&n);
		for(i=1;i<=m;i++)
		{
			pre1[i]=i;
			pre2[i]=i;
		}
		for(i=0;i<n;i++)
			scanf("%d %d %d",&s[i].a,&s[i].b,&s[i].c);
		sort(s,s+n,cmp);
		int min1=0,min2=0,num=0;
		for(i=0;i<n && num<n-1;i++)
		{
			int r1=s[i].a,r2=s[i].b;
			while(r1!=pre1[r1])
				r1=pre1[r1]; 
			while(r2!=pre1[r2])
				r2=pre1[r2];
			if(r1!=r2)
			{
				pre1[r2]=r1;
				min1+=s[i].c;
				s[i].d=1;//标记这条边已经用过了; 
				num++;
			}
		}
		num=0;
		bool ans=true;
		sort(s,s+n,cmp);
		for(i=0;i<n && num<n-1;i++)
		{
			int r1=s[i].a,r2=s[i].b;
			while(r1!=pre2[r1])
				r1=pre2[r1]; 
			while(r2!=pre2[r2])
				r2=pre2[r2];
			if(r1!=r2)
			{
				pre2[r2]=r1;
				min2+=s[i].c;
				num++;
				if(s[i].d==-1)//如果用到第一次没有用到的边; 
					ans=false;
			}
		}
		if(min1==min2 && !ans)//总权值相等且用到了不同的边; 
			printf("Not Unique!\n");
		else
			printf("%d\n",min1);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
prim_mst构造最小生成树的思想是通过贪心算法逐步选择边来构建最小生成树。具体步骤如下: 1. 创建一个空的最小生成树MST和一个空的集合visited,用于存储已经访问过的顶点。 2. 选择一个起始顶点作为根节点,并将其加入visited集合。 3. 从根节点开始,遍历与根节点相邻的边,并选择权重最小的边。 4. 将选择的边加入MST,并将边的另一个顶点加入visited集合。 5. 重复步骤3和步骤4,直到visited集合包含所有顶点。 6. 最终得到的MST就是原图的最小生成树。 以下是使用prim_mst构造最小生成树的示例代码: ```python import numpy as np def prim_mst(graph): num_vertices = len(graph) MST = [] visited = set() # 选择起始顶点 start_vertex = 0 visited.add(start_vertex) while len(visited) < num_vertices: min_weight = np.inf min_edge = None # 遍历已访问的顶点 for vertex in visited: # 遍历与已访问顶点相邻的边 for neighbor, weight in enumerate(graph[vertex]): # 如果边的另一个顶点未访问且权重更小,则更新最小边 if neighbor not in visited and weight < min_weight: min_weight = weight min_edge = (vertex, neighbor) # 将最小边加入MST,并将边的另一个顶点加入visited集合 MST.append(min_edge) visited.add(min_edge[1]) return MST # 示例输入矩阵 graph = np.array([[0, 192, 344, 0, 0, 0, 0, 0, 0, 0, 0], [192, 0, 309, 0, 555, 0, 0, 0, 0, 0, 0], [344, 309, 0, 499, 0, 0, 0, 0, 0, 0, 0], [0, 0, 499, 0, 840, 0, 229, 286, 0, 0, 0], [0, 555, 0, 840, 0, 237, 0, 0, 0, 0, 0]]) # 构造最小生成树 MST = prim_mst(graph) print("Minimum Spanning Tree:") for edge in MST: print(edge) ``` 输出结果为最小生成树的边集合。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值