poj 2456【最大化最小值】

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14728 Accepted: 7098

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3
思路:先sort,第一头牛放在x[0]位置,往后进行贪心;

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define max_n 100010
#define INF 0x3f3f3f3f
using namespace std;
typedef long long LL;
int x[max_n];
int n,m;

bool judge(int d)
{
	int last=0;
	for(int i=1;i<m;i++)
	{
		int cnt=last+1;
		while(cnt<n && x[cnt]-x[last]<d)
		{
			cnt++;
		}
		if(cnt==n) return false;
		last=cnt;
	}
	return true;
}

int main()
{
	memset(x,0,sizeof(x));
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++)
		scanf("%d",&x[i]);
	sort(x,x+n);
	int l=0,r=INF,mid;
	while(r-l>1)
	{
		mid=(l+r)>>1;
		if(judge(mid)) l=mid;
		else r=mid;
	}
	printf("%d\n",l);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值