poj 1273 Drainage Ditches【最大流 EK || dinic】

Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output

50

EK:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;

const int INF = 0x3f3f3f3f;
const int MAXN = 210;
int c[MAXN][MAXN], f[MAXN], pre[MAXN];
int n, m;

int BFS(int st, int ed) {
    memset(pre, -1, sizeof(pre));
    pre[st] = 0;
    queue<int> que;
    f[st] = INF;
    que.push(st);
    while(!que.empty()) {
        int x = que.front();
        que.pop();
        if(x == ed) break;
        for(int i = 1; i <= m; ++i) {
            if(i != st && c[x][i] > 0 && pre[i] == -1) {
                pre[i] = x;
                f[i] = min(f[x], c[x][i]);
                que.push(i);
            }
        }
    }
    if(pre[ed] < 0) return -1;
    return f[ed];
}

int Max_flow(int st, int ed) {
    int sum = 0;
    while(1) {
        int ans = BFS(st, ed);
        if(ans < 0) break;
        sum += ans;
        int x = ed;
        while(x) {
            c[pre[x]][x] -= ans;
            c[x][pre[x]] += ans;
            x = pre[x];
        }
    }
    return sum;
}

int main()
{ 
    while(scanf("%d %d", &n, &m) != EOF) {
        memset(c, 0, sizeof(c));
        memset(f, 0, sizeof(f));
        for(int i = 0; i < n; ++i) {
            int a, b, cos;
            scanf("%d %d %d", &a, &b, &cos);
            if(a == b) continue;
            c[a][b] += cos;
        }
        printf("%d\n", Max_flow(1, m));
    }
    return 0;
}

Dinic:

#include <cstdio>  
#include <cstring>   
#include <queue>  
#include <algorithm>  
#define MAXN 200+10  
#define INF 0x3f3f 
using namespace std;
int dist[MAXN], cur[MAXN], vis[MAXN], head[MAXN], top;
int n, m;

struct Edge {
    int to, cap, flow, next;
}edge[MAXN << 2];

void addedge(int a, int b, int c) {
    Edge E1 = {b, c, 0, head[a]};
    edge[top] = E1;
    head[a] = top++;
    Edge E2 = {a, 0, 0, head[b]};
    edge[top] = E2;
    head[b] = top++;
}

bool BFS(int start, int end) { //spfa法求最短路 
    memset(dist, -1, sizeof(dist));  
    memset(vis, 0, sizeof(vis));  
    queue<int> Q; 
    Q.push(start);
    vis[start] = 1;
    dist[start] = 0; 
    while(!Q.empty()) {
        int u = Q.front();
        Q.pop();
        for(int i = head[u]; i != -1; i = edge[i].next) {
            Edge E = edge[i];
            if(!vis[E.to] && E.cap > E.flow) { //多个流限制 
                dist[E.to] = dist[u] + 1; //建立分层 
                vis[E.to] = 1;
                if(E.to == end) return true;
                Q.push(E.to);
            }
        }
    }
    return false;
}

int DFS(int x, int cost, int end) { //根据分层图进行深搜 
    if(x == end || cost == 0) return cost;
    int flow = 0, f;
    for(int& i = cur[x]; i != -1; i = edge[i].next) {
        Edge& E = edge[i];
        if(dist[E.to] == dist[x] + 1 &&  (f = DFS(E.to, min(cost, E.cap - E.flow), end)) > 0) { 
            E.flow += f;
            edge[i ^ 1].flow -= f;
            flow += f;
            cost -= f;
            if(cost == 0) break;
        }
    }
    return flow;
}

int Maxflow(int start, int end) {
    int flow = 0;
    while(BFS(start, end)) { //对残量网络增广 
        memcpy(cur, head, sizeof(head));
        flow += DFS(start, INF, end);
    }
    return flow;
}

int main() {
    while(scanf("%d %d", &m, &n) != EOF) {
        top = 0;
        memset(head, -1, sizeof(head));
        int a, b, c;
        while(m--) {
            scanf("%d %d %d", &a, &b, &c);
            addedge(a, b, c);
        }
        printf("%d\n", Maxflow(1, n));
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值