LightOJ 1030 Discovering Gold【概率dp】

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.
Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.
Output
For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.
Sample Input
3
1
101
2
10 3
3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15
题意:一个1*N的格子里,每个格子都有相应的金币数,走到相应格子的话,就会得到该格子的金币。 现在有一个人在1这个位置出发,手里有一颗骰子,骰子摇到几,他就前进几步,但有一种情况例外,如果当前位置+色子数 > N,那么他就会重新摇色子(要在N之前)。 走到N这个位置的话,意味着游戏结束了。 问游戏结束时,这个人得到金币的期望。
思路:一直错,看着题解看明白了。逆着推:
第N个位置获得的金币:dp[N] = a[N];
第N - 1个位置获得的金币:dp[N - 1] = a[N - 1] + dp[N] / 1;
第N - 2个位置获得的金币:dp[N - 2] = a[N - 2] + dp[N - 1] / 2 + dp[N] / 2;
……
第i个位置获得的金币:dp[i] = a[i] + dp[i + 1] / min(6, n - i) + dp[i + 2] / min(6, n - i) +····· dp[i + min(6, n - i)] / min(6, n - i) ;(特判不足6的位置)

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
using namespace std;
double a[110], dp[110];

int main() {
    int t, p = 1, n;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            scanf("%lf", &a[i]);
        }
        dp[n] = a[n];
        for(int i = n - 1; i >= 1; i--) {
            int cnt = n - i;
            dp[i] = a[i];
            for(int j = 1; j <= min(6, cnt); j++) {
                dp[i] = dp[i] + dp[i + j] / min(cnt, 6);
            }
        }
        printf("Case %d: ", p++);
        printf("%.8lf\n", dp[1]);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值