LightOJ - 1259 Goldbach`s Conjecture【素筛&小细节】

LightOJ - 1259 Goldbach`s Conjectur.

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where
1) Both a and b are prime
2) a + b = n
3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Hint
1. An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …

题意:
给你一个n,满足哥德巴赫猜想的组数 (n=a+b(a,b)) ( n = a + b , ( a , b ) 均 为 质 数 ) .
分析:
一个素筛+打表就好,但是内存有限制,小技巧点:筛素数时用bool类型定义数组.

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long LL;

const int MAXN = 1e7 + 5;
bool a[MAXN];
int b[2000000];
int p = 0;

void init() {
    a[0] = a[1] = 1;
    for(int i = 2; i * i < MAXN; ++i) {
        if(a[i]) continue;
        for(int j = i * i; j < MAXN; j += i) {
            a[j] = 1;
        }
    }
    for(int i = 0; i < MAXN; i++) {
        if(!a[i]) {
            b[p++] = i;
        }
    }
    //printf("%d\n", p);
}

int main() {
    init();
    int T, n;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        int ans = 0;
        for(int i = 0; i < p; i++) {
            if(n / 2 < b[i]) break;
            if(!a[n - b[i]]) ans++;
        }
        static int t = 1;
        printf("Case %d: %d\n", t++, ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值