Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.
Input
The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output
For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.
The first network in the file should be identified as “Network #1”, the second as “Network #2”, etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text “No SPF nodes” instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0
1 2
2 3
3 4
4 5
5 1
0
1 2
2 3
3 4
4 6
6 3
2 5
5 1
0
0
Sample Output
Network #1
SPF node 3 leaves 2 subnets
Network #2
No SPF nodes
Network #3
SPF node 2 leaves 2 subnets
SPF node 3 leaves 2 subnets
题意:给你一个无向图,让你分别求割点及其所分出的连通块数量;
分析:用割点的两个性质,预处理连通块的数量,直接输出;
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
typedef long long LL;
const int MAXN = 1e3 + 10;
int head[MAXN], low[MAXN], dfn[MAXN], stack[MAXN], add_block[MAXN];
bool cut[MAXN], instack[MAXN];
int cnt, index, top, bridge;
struct Edge {
int to;
int next;
bool cut_;
}edge[MAXN * MAXN];
void addedge(int u, int v) {
edge[cnt].to = v;
edge[cnt].next = head[u];
edge[cnt].cut_ = false;
head[u] = cnt++;
}
void tarjan(int u, int fa) {
int v;
low[u] = dfn[u] = ++index;
stack[top++] = u;
instack[u] = true;
int son = 0;
for(int i = head[u]; ~i; i = edge[i].next) {
v = edge[i].to;
if(v == fa) continue;
if(!dfn[v]) {
son++;
tarjan(v, u);
low[u] = min(low[u], low[v]);
if(low[v] > dfn[u]) { //无向边(u,v)是桥,当且仅当(u,v)为树枝边,且满足dfn[u]<low[v];
bridge++;
edge[i].cut_ = true;
edge[i^1].cut_ = true; //无向边存储
}
if(u != fa && low[v] >= dfn[u]) { //u不为树根,且满足(u,v)为树枝边,使得dfn[u]<=low[v]
cut[u] = true;
add_block[u]++; //去除该点,得到的连通快
}
}
else {
low[u] = min(dfn[v], low[u]);
}
}
if(u == fa && son > 1) cut[u] = true; //u为树根,子树大于1
if(u == fa) add_block[u] = son - 1;
instack[u] = false;
top--;
}
void init() {
memset(head, -1, sizeof(head));
memset(add_block, 0, sizeof(add_block));
memset(dfn, 0, sizeof(dfn));
memset(instack, 0, sizeof(instack));
memset(cut, 0, sizeof(cut));
cnt = index = top = bridge = 0;
}
void solve(int n) {
for(int i = 1; i <= n; ++i) {
if(!dfn[i]) {
tarjan(i, i);
}
}
bool flag = false;
for(int i = 1; i <= n; ++i) {
if(cut[i]) {
flag = true;
printf(" SPF node %d leaves %d subnets\n", i, add_block[i] + 1);
}
}
if(!flag) {
printf(" No SPF nodes\n");
}
puts("");
}
int main() {
int n, m, p = 1, k;
while(scanf("%d", &n) && n) {
init();
scanf("%d", &m);
addedge(n, m);
addedge(m, n);
k = max(n, m);
while(scanf("%d", &n) && n) {
scanf("%d", &m);
addedge(n, m);
addedge(m, n);
k = max(k, max(n, m));
}
printf("Network #%d\n", p++);
solve(k);
}
return 0;
}