HDU 4738 Caocao's Bridges【边双联通--权值最小+重边】

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.
Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
Sample Output
-1
4

题意:给你一个无向图,让你求出权值最小的桥;
分析:感觉是很简单,细节很多。当这个图不是联通图的时候,直接输出0;当最小权值的桥是0时,输出1;最最难受的就是重边,这里的重边不能直接跳过建图,必须也用到(路径多条的情况),处理是否是桥的时候用一个邻接矩阵判断是否有重边。由于数据范围比较小,我处理重边时用了两个邻接矩阵。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
typedef long long LL;

const int MAXN = 1e3 + 10;
int head[MAXN], low[MAXN], dfn[MAXN], mapp[MAXN][MAXN], ma[MAXN][MAXN];
int cnt, index, top, ans;

struct Edge {
    int to;
    int next;
}edge[MAXN * MAXN * 2];

void addedge(int u, int v) {
    edge[cnt].to = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}

void tarjan(int u, int fa) {
    low[u] = dfn[u] = ++index;
    for(int i = head[u]; ~i; i = edge[i].next) {
        int v = edge[i].to;
        if(v == fa) continue;
        if(!dfn[v]) {
            tarjan(v, u);
            low[u] = min(low[u], low[v]);
            if(low[v] > dfn[u] && ma[u][v] == 1) {
                ans = min(ans, mapp[u][v]);
            }
        }
        else {
            low[u] = min(dfn[v], low[u]);
        }
    }
}

void init() {
    memset(head, -1, sizeof(head));
    memset(dfn, 0, sizeof(dfn));
    cnt = index = 0;
    ans = 1e8;
    for(int i = 0; i < MAXN; i++) {
        for(int j = 0; j < MAXN; j++) {
            mapp[i][j] = 1e8;
            ma[i][j] = 0;
        }
    }
}

void solve(int n) {
    int tt = 0;
    for(int i = 1; i <= n; ++i) {
        if(!dfn[i]) {
            tt++;
            tarjan(i, i);
        }
    }
    if(tt > 1) {
        printf("0\n");
        return ;
    }
    if(ans != 1e8) {
        if(ans == 0) printf("1\n");
        else printf("%d\n", ans);
    }
    else printf("-1\n");
}

int main() {
    int n, m, a, b, c;
    while(scanf("%d %d", &n, &m) && n + m) {
        init();
        while(m--) {
            scanf("%d %d %d", &a, &b, &c);
            addedge(a, b);
            addedge(b, a);
            ma[a][b]++;
            ma[b][a]++;
            mapp[a][b] = min(mapp[a][b], c);
            mapp[b][a] = mapp[a][b];
        }
        solve(n);
    }
    return 0; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值