Prime Path

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

    1033
    1733
    3733
    3739
    3779
    8779
    8179 

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased. 

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

这个题感觉还好,一看过去就知道这是用BFS(),因为说的是最短么,所以我们用bfs()就好了,主要就是这些操作,一个数我们要四次操作。每次操作10个方向,还是很麻烦的。

#include <cstdio>
#include<queue>
#include<cstring>
using namespace std;

int flag[12];
int vis[10000];
int prime[10000]={0,0};
int a,b;
//素数打表
void is_prime()
{
    for(int i=2;i<=9999;i++)
        prime[i]=1;
    for(int i=2;i<=9999;i++)
    {
        if(prime[i])
        {
            for(int j=i*2;j<=9999;j+=i)
                prime[j]=0;//我的个神啊,这个地方我给写错了,气死我了
        }
    }
}

typedef struct node
{
    int x;
    long long  step;
    friend bool operator <(node a,node b)
    {
        return a.step>b.step;
    }
}Node;


int check(int x)
{
    if(x<1000||x>9999||vis[x])
        return 1;
    return 0;
}

int bfs()
{
   priority_queue<Node> pq;
   while(pq.size())
     pq.pop();
   memset(vis,0,sizeof(vis));
   Node now,next;

   now.x=a,now.step=0;//参变量不要过多
   vis[a]=1;
   pq.push(now);
   while(pq.size())
   {
       now=pq.top();
       pq.pop();

       if(now.x==b)
          return now.step;

       int ge=now.x%10,shi=now.x/10%10,bai=now.x/100%10,qian=now.x/1000;
       //个位

       memset(flag,0,sizeof(flag));
       flag[ge]=1;
       for(int j=1;j<=9;j+=2)
       {
           if(!flag[j])
           {
               int temp=j+shi*10+bai*100+qian*1000;
               if(!check(temp)&&prime[temp])
               {
                   next.x=temp,next.step=now.step+1;
                   pq.push(next);
               }
               vis[temp]=1;
           }
       }

       memset(flag,0,sizeof(flag));
       flag[shi]=1;
       for(int j=0;j<=9;j++)
       {
           if(!flag[j])
           {
               int temp=ge+j*10+bai*100+qian*1000;
               if(!check(temp)&&prime[temp])
               {
                   next.x=temp,next.step=now.step+1;
                   pq.push(next);
               }
               vis[temp]=1;
           }
       }

       memset(flag,0,sizeof(flag));
       flag[bai]=1;
       for(int j=0;j<=9;j++)
       {
           if(!flag[j])
           {
               int temp=ge+shi*10+j*100+qian*1000;
               if(!check(temp)&&prime[temp])
               {
                   next.x=temp,next.step=now.step+1;
                   pq.push(next);
               }
               vis[temp]=1;
           }
       }

       memset(flag,0,sizeof(flag));
       flag[qian]=1;
       for(int j=1;j<=9;j++)
       {
           if(!flag[j])
           {
               int temp=ge+shi*10+bai*100+j*1000;
               if(!check(temp)&&prime[temp])
               {
                   next.x=temp,next.step=now.step+1;
                   pq.push(next);
               }
               vis[temp]=1;
           }
       }
   }
   return -1;
}


int main()
{
   is_prime();
   int n;
   int ans;
   scanf("%d",&n);
   for(int i=1;i<=n;i++)
   {
        scanf("%d%d",&a,&b);
        ans=bfs();
        if(ans==-1)
            printf("Impossible\n");
        else
            printf("%d\n",ans);
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值