Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2


我们要想知道一个点的rank排名的话,我们必须知道他和剩余n-1的关系都确定之后,才能确定。我们用floyd来确定一个人和所有人的关系。

#include <cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long ll;

int N,M;
int mp[110][110];
const int INF=0x3f3f3f3f;

void floyd(){

    for(int k=1;k<=N;k++){
        for(int i=1;i<=N;i++){
            for(int j=1;j<=N;j++){
                if(mp[i][k]==mp[k][j]&&mp[i][k]!=INF){//如果说i->k的关系确定,k->j的关系确定的话,i->j的关系就确定了
                    mp[i][j]=mp[i][k];
                }
            }
        }
    }
}

int main()
{
   scanf("%d %d",&N,&M);
   memset(mp,INF,sizeof(mp));
   for(int i=1;i<=M;i++){
    int u,v;
     scanf("%d %d",&u,&v);
     mp[u][v]=1;
     mp[v][u]=-1;
   }
   floyd();
   int ans=0;
   for(int i=1;i<=N;i++){
     int sum=0;
     for(int j=1;j<=N;j++){
        if(mp[i][j]!=INF)
            sum++;
     }
     if(sum==N-1)
        ans++;
   }
   printf("%d\n",ans);
   return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值