String painter

点击打开链接

Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
 
 
zzzzzfzzzzzabcdefedcbaababababababcdcdcdcdcdcd
 
Sample Output
 
 
6

这道题的区间划分不是特别明显,但是他是在暴力求解,划分区间

#include<cstdio>
#include<cstring>
#include<algorithm>
typedef long long ll;
using namespace std;

const int maxn=110;
const int INF=0x3f3f3f3f;
int dp[maxn][maxn];
char s1[maxn],s2[maxn]; 
int ans[maxn];

int main(){
	while(~scanf(" %s %s",&s1,&s2)){
		int len=strlen(s1);
		memset(dp,0,sizeof(dp));
		for(int j=0;j<len;j++){//i-j区间,从空白字符来的最先涂的次数 
			for(int i=j;i>=0;i--){
				dp[i][j]=1+dp[i+1][j];
				for(int k=i+1;k<=j;k++){
					if(s2[i]==s2[k])
					dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
				}
			}
		} 
		for(int i=0;i<len;i++) ans[i]=dp[0][i];
		for(int i=0;i<len;i++){
			if(s1[i]==s2[i]){//当前可以不涂 
				ans[i]=i==0?0:ans[i-1];
			}
			else{//必须涂的话,我们需要枚举 i延展到哪里最好 
				for(int k=0;k<i;k++)
				ans[i]=min(ans[i],ans[k]+dp[k+1][i]);
			}
		}
		printf("%d\n",ans[len-1]);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值