The Embarrassed Cryptographer poj-2635(同余定理)

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=1e5+10;

char str[maxn];
int real_num[maxn];
int num[maxn],vis[maxn*10];

/*
注意这里我们要是要素数的话,注意这个范围,
或者是取的方式 
*/ 
void init(int& cnt){
	for(int i=2;i<=1000000;i++){
		if(!vis[i]){
			num[cnt++]=i;
			for(int j=i*2;j<=1000000;j+=i)
				vis[j]=1;
		}	
	}
}

void get_realnum(int& len){
	int cnt=0;
	for(int i=len-1;i>=0;i-=3){
		if(i>=2){
			real_num[cnt++]=(str[i]-'0')+(str[i-1]-'0')*10+(str[i-2]-'0')*100;
		}	
		else if(i==1){
			real_num[cnt++]=(str[i]-'0')+(str[i-1]-'0')*10;
		}
		else{
			real_num[cnt++]=str[i]-'0';
		}
	}
	len=cnt;
}

int judge(int pos,int len){
	int ans=0;
	for(int i=len-1;i>=0;i--){
		ans=(ans*1000%num[pos]+real_num[i])%num[pos];
	}
	return ans==0;
}

int check(int cnt,int& pos,int k){
	int len=strlen(str);
	get_realnum(len);//改成千位数字,要不然会超时 
	for(int i=0;i<cnt;i++){
		if(num[i]>=k) return 0;
		if(judge(i,len)){
			pos=i;
			return 1;
		} 
	}
	return 0;
}

int main(){
	int cnt=0;
	init(cnt);
	int b;
	while(scanf("%s %d",str,&b)){
		if(!strcmp(str,"0")&&!b){
			break;
		}
		int pos;
		int ans=check(cnt,pos,b);
		if(!ans)
			printf("GOOD\n");
		else{
			printf("BAD %d\n",num[pos]);
		}
	}
	return 0;
}
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=1e5+10;

char str[maxn];
int real_num[maxn];
ll num[maxn];
int vis[maxn*10];

/*
注意这里我们要是要素数的话,注意这个范围,
或者是取的方式 
*/ 
void init(int& cnt){
	for(int i=2;i<=1000000;i++){
		if(!vis[i]){
			num[cnt++]=i;
			for(int j=i*2;j<=1000000;j+=i)
				vis[j]=1;
		}	
	}
}

void get_realnum(int& len){
	int cnt=0;
	for(int i=len-1;i>=0;i-=4){
		if(i>=3){
			real_num[cnt++]=(str[i]-'0')+(str[i-1]-'0')*10+(str[i-2]-'0')*100+(str[i-3]-'0')*1000;
		}	
		else if(i==2){
			real_num[cnt++]=(str[i]-'0')+(str[i-1]-'0')*10+(str[i-2]-'0')*100;
		}
		else if(i==1){
			real_num[cnt++]=(str[i]-'0')+(str[i-1]-'0')*10;
		}
		else{
			real_num[cnt++]=str[i]-'0';
		}
	}
	len=cnt;
}

int judge(int pos,int len){
	ll ans=0;
	for(int i=len-1;i>=0;i--){
		ans=(ans*10000%num[pos]+real_num[i])%num[pos];
	}
	return ans==0;
}

int check(int cnt,int& pos,int k){
	int len=strlen(str);
	get_realnum(len);//改成千位数字,要不然会超时 ,改成万位,不过要用long long ,上面的judge函数可能会爆掉 
	for(int i=0;i<cnt;i++){
		if(num[i]>=k) return 0;
		if(judge(i,len)){
			pos=i;
			return 1;
		} 
	}
	return 0;
}

int main(){
	int cnt=0;
	init(cnt);
	int b;
	while(scanf("%s %d",str,&b)){
		if(!strcmp(str,"0")&&!b){
			break;
		}
		int pos;
		int ans=check(cnt,pos,b);
		if(!ans)
			printf("GOOD\n");
		else{
			printf("BAD %d\n",num[pos]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值