Time Zone(时间转换,注意精度)

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input

3  11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

Sample Output

11:11 12:12 03:23

#include<bits/stdc++.h>
using namespace std;
const int N=1e3+10;

int main(){
//我的代码
/*
    int T;
    scanf("%d",&T);
    int h,m;double dd;
    while(T--){
        char ch;
        scanf("%d %d UTC%c%lf",&h,&m,&ch,&dd);
        double tmp=dd;
        if(ch=='-')dd*=-1;
        dd=fabs(8.0-dd);
        dd*=60;
        int d=dd+0.5;//!!!精度
        if(ch=='+'&&tmp>=8.0){
            while(d){
                    m++;
                    if(m>=60){
                        m=0;
                        h++;
                        if(h>=24){
                            h=0;
                        }
                    }
                    d--;
            }
        }
        else{
            while(d){
                m--;
                if(m<=-1){
                    m=59;
                    h--;
                    if(h<0){
                        h=23;
                    }
                }
                d--;
            }
        }
        printf("%02d:%02d\n",h,m);
    }
*/

//dls的思路
/*
dls把所有的时间都转换成分钟,然后加加减减
*/
///!!!
    int T;
    scanf("%d",&T);
    while(T--){
        int h,m;
        char s[10];
        scanf("%d %d %s",&h,&m,s);
        int sign=(s[3]=='+'?1:-1);
        double d;
        sscanf(s+4,"%lf",&d);//!!!从字符串中,按照格式读取数字

        int c=(int)((d+0.01)*60);//!!!精度
        c*=sign;
        c -= 8*60;//计算偏移量
        m=h*60+m;//计算基准时间
        m+=c;
      //  printf("d:%.2f dd:%d c:%d\n",d,dd,c);
        //!!!每天其实都是24*60,所以只要mod之后,在这里面就可以了,太牛逼了(维度很高)
        m%=(24*60);
        if(m<0)m+=24*60;
        printf("%02d:%02d\n",m/60,m%60);
    }
///!!!
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值