4391: [Usaco2015 dec]High Card Low Card

Description

Bessie the cow is a huge fan of card games, which is quite surprising, given her lack of opposable thumbs. Unfortunately, none of the other cows in the herd are good opponents. They are so bad, in fact, that they always play in a completely predictable fashion! Nonetheless, it can still be a challenge for Bessie to figure out how to win.

Bessie and her friend Elsie are currently playing a simple card game where they take a deck of 2N cards, conveniently numbered 1…2N, and divide them into N cards for Bessie and N cards for Elsie. The two then play NN rounds, where in each round Bessie and Elsie both play a single card. Initially, the player who plays the highest card earns a point. However, at one point during the game, Bessie can decide to switch the rules so that for the rest of the game, the player who plays the lowest card wins a point. Bessie can choose not to use this option, leaving the entire game in "high card wins" mode, or she can even invoke the option right away, making the entire game follow the "low card wins" rule.

Given that Bessie can predict the order in which Elsie will play her cards, please determine the maximum number of points Bessie can win.

 

奶牛Bessie和Elsie在玩一种卡牌游戏。一共有2N张卡牌,点数分别为1到2N,每头牛都会分到N张卡牌。

游戏一共分为N轮,因为Bessie太聪明了,她甚至可以预测出每回合Elsie会出什么牌。

每轮游戏里,两头牛分别出一张牌,点数大者获胜。

同时,Bessie有一次机会选择了某个时间点,从那个时候开始,每回合点数少者获胜。

Bessie现在想知道,自己最多能获胜多少轮?

 

Input

The first line of input contains the value of N (2≤N≤50,000).

The next N lines contain the cards that Elsie will play in each of the successive rounds of the game. Note that it is easy to determine Bessie's cards from this information.

Output

Output a single line giving the maximum number of points Bessie can score.

Sample Input

4
1
8
4
3

Sample Output

3

HINT

 

Here, Bessie must have cards 2, 5, and 6, and 7 in her hand, and she can use these to win at most 3 points. For example, she can defeat the 1 card and then switch the rules to "low card wins", after which she can win two more rounds.

 

算是思维题吧。

我们想到的算法都是n^2 的,以为10s就能过。

事实就是我们可以  预处理一下 数据,正方向和反方向各自处理一遍。(主要是证明 两者确实不会冲突)

然后就是证明一下  可行性。

假设  X 匹配到了  上和下 ,但是肯定会有一个 Y 没有被匹配,如果 y>x, 那么我们可以 让 y匹配上面的选项,如果y<x相反即可。

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)

const int N=50010;

int book[N*2],val[N];
int arr[N],v1[N],v2[N];

int main(){
	
	int n;
	scanf("%d",&n);
	rep(i,1,n+1){
		scanf("%d",&val[i]);
		book[val[i]]=1;
	} 
	
	int p=1;
	for(int i=1;i<=2*n;i++){
		if(!book[i]){
			arr[p++]=i;
		}
	}
	
	set<int> s1;
	for(int i=1;i<=n;i++){
		s1.insert(arr[i]);		
	}
	
	for(int i=1;i<=n;i++){	
		set<int>::iterator it=s1.upper_bound(val[i]);
		if(it!=s1.end()){
		//	printf("i:%d val:%d %d\n",i,val[i],*it);
			s1.erase(it);
			v1[i]=v1[i-1]+1;
		}else{
			v1[i]=v1[i-1];
		}
	}
	
	s1.clear();
	for(int i=1;i<=n;i++){
		s1.insert(-arr[i]);
	}
	
	for(int i=n;i>=1;i--){
		set<int>::iterator it=s1.upper_bound(-val[i]);
		if(it!=s1.end()){
			s1.erase(it);
			v2[i]=v2[i+1]+1;
		}else{
			v2[i]=v2[i+1];
		}
	}
	
	//for(int i=1;i<=n;i++)printf("i:%d  %d %d\n",i,v1[i],v2[i]);
	
	int ans=0;
	for(int i=0;i<=n;i++){
		ans=max(ans,v1[i]+v2[i+1]);
	}
	printf("%d\n",ans);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值