WOJ-351 Olympic

“One World One Dream” fully reflects the essence and the universal values of the Olympic spirit ---- Unity, Friendship, Progress, Harmony,
Participation and Dream. It expresses the common wishes of people all over the world, inspired by the Olympic ideals, to strive for a bright future
of Mankind. In spite of the differences in colors, languages and races, we share the charm and joy of the Olympic Games, and together we seek for the ideal of Mankind for peace. We belong to the same world and we share the same aspirations and dreams.

“One World One Dream” is a profound manifestation of the core concepts of the Beijing Olympic Games. It reflects the values of harmony connoted in the concept of “People’s Olympics”, the core and soul of the three concepts – “Green Olympics, High-tech Olympics and People’s Olympics”.
While “Harmony of Man with Nature” and “Peace Enjoys Priority” are the philosophies and ideals of the Chinese people since ancient times in their pursuit of the harmony between Man and Nature and the harmony among people, building up a harmonious society and achieving harmonious
development are the dream and aspirations of ours. It is our belief that peace and progress, harmonious development, living in amity, cooperation and mutual benefit, and enjoying a happy life are the common ideals of the people throughout the world.

“One World, One Dream” is simple in expressions, but profound in meaning. It is of China, and also of the world. It conveys the lofty ideal of the
people in Beijing as well as in China to share the global community and civilization and to create a bright future hand in hand with the people from the rest of the world. It expresses the firm belief of a great nation, with a long history of 5,000 years and on its way towards modernization, that
is committed to peaceful development, harmonious society and people’s happiness. It voices the aspirations of 1.3 billion Chinese people to
contribute to the establishment of a peaceful and bright world.

The English translation of the slogan is distinctive in sentence structure. The two "One"s are perfectly used in parallel, and the words “World” and “Dream” form a good match. The slogan is simple, meaningful, inspiring, and easy to remember, read and spread.

In Chinese, the word “tongyi”, which means “the same”, is used for the English word “One”. It highlights the theme of “the whole Mankind lives in the same world and seeks for the same dream and ideal”.

Please help us write a program to count down days to the upcoming Beijing 2008 Olympic games.

输入格式

The first line contains an integer T indicating the number of test cases.
In the next T lines, each line contains two integers “month” and “day” indicating one day in the future.

输出格式

Output T lines. Each line contains an integer indicating the number of days.

样例输入

1
3 15

样例输出

146

提示

Don’t know when the Olympic begins?
Just refer to the sample test case.

说了那么多其实很简单,问的是08年的日期离8月8有多久,直接case语句都能做

#include<stdio.h>
int main(){
	int T;
	scanf("%d",&T);
	for(int i=0;i<T;i++){
		int M,D;
		scanf("%d %d",&M,&D);
		switch(M){
			case 8: printf("%d\n",8-D); break;
			case 7: printf("%d\n",39-D); break;
			case 6: printf("%d\n",69-D); break;
			case 5: printf("%d\n",100-D); break;
			case 4: printf("%d\n",130-D); break;
			case 3: printf("%d\n",161-D); break;
			case 2: printf("%d\n",190-D); break;
			case 1: printf("%d\n",221-D); break;
			default: return 1; break;
		}		
	}
	return 0;
}

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值