关于PAT A1016 Phone Bills遇到的坑

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

这道题把我粗心的毛病暴露一干二净,所遇到的坑记录如下:

  1. 关于%2d和%.2f这类型的输出 (%2d作用 1->01,%.2f作用6->6.00)。
  2. (float)(a/100)和a/100.0 前者先转整后转浮点,(float)(10/100)=0.0,而10/100.0=0.1。
  3. 这里有一个要注意的,有的人打了电话但他可能只有on-line或offf-line,也就是无有效通话,这时候不应该记录“CYLL 01"(只是我这种写法需要注意这种事情)。
  4. 判断当前flag和下一个flag是否分别等于0和1的时候(即判断是否有一通有效电话),有可能a[i+1]是另外一个人,这时候是不能作为一有效电话的。
  5. 这就坑爹了,正常来说打电话也就几个小时,所以隔天的电话也就是一天,但是题目里面显然是可以打个两三个天的!我没有注意到这点(搞得我一直答案错误),后来发现题目中给的样例就包括了打了几天的情况!! 输入输出样例一定要仔细看!!
  6. 关于字符串的赋值,我又一次**了,直接用a=b。。。应该用strcpy(a,b)的。
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct node{
	char name[22];
	int data[4];  //月 日 时 分 
	int flag;     //0 online 1 offline 
}a[1010]; 
int toll[25];    //分时段每分钟费用 
int time;           //一次通话时间 
bool cmp(node b,node c){
	int k=strcmp(b.name,c.name);
	if(k!=0)  return k<0;
	else if(b.data[0]!=c.data[0]) return b.data[0]<c.data[0];
	else if(b.data[1]!=c.data[1]) return b.data[1]<c.data[1];
	else if(b.data[2]!=c.data[2]) return b.data[2]<c.data[2];
	else return b.data[3]<c.data[3];
}
int cal(node m,node n){
	int money=0;
	if(m.data[1]<n.data[1]){      //跨天电话       ///这里我只考虑了隔一天的情况,事实上可以隔很多天!!! 
	    time=(n.data[1]-m.data[1]-1)*1440;
	    if(time!=0){
	    	for(int i=0;i<24;i++){
	    		money=60*toll[i]+money;	    		
			}
			money=money*(n.data[1]-m.data[1]-1);
		}
		while(m.data[2]!=24){
			money=(60-m.data[3])*toll[m.data[2]]+money;
			time=(60-m.data[3])+time;
			m.data[2]++;
			m.data[3]=0;
		}
		while(n.data[2]>=0){
			money=n.data[3]*toll[n.data[2]]+money;
			time=n.data[3]+time;
			n.data[2]--;
			n.data[3]=60;
		}
	}
	else if(m.data[2]!=n.data[2]){        //当天电话且不同小时 
		while(m.data[2]<n.data[2]){
			money=(60-m.data[3])*toll[m.data[2]]+money;
			time=(60-m.data[3])+time;
			m.data[2]++;
			m.data[3]=0;
		}
		money=n.data[3]*toll[n.data[2]]+money;
		time=n.data[3]+time;
	}
	else if(m.data[2]==n.data[2]){       //当天电话同一小时 
		money=(n.data[3]-m.data[3])*toll[m.data[2]];
		time=n.data[3]-m.data[3]; 
	} 
	return money;
}
int main(){
	
	char tempname[22]={0};   //当前姓名 
	for(int i=0;i<24;i++){
		scanf("%d",&toll[i]);
	}
	int N;
	scanf("%d",&N);            //用户数目 
	char line[10];  
	for(int i=0;i<N;i++){
		scanf("%s %d:%d:%d:%d %s",a[i].name,&a[i].data[0],&a[i].data[1],&a[i].data[2],&a[i].data[3],line);
		if(strcmp(line,"on-line")==0) a[i].flag=0;
		else if(strcmp(line,"off-line")==0) a[i].flag=1;
	}
	sort(a,a+N,cmp);
	int tempmoney=0;   //当前的钱 
	int first;
	for(int i=0;i<N;i++){
		if(strcmp(a[i].name,tempname)!=0){             //首次发现这个人的名字 	 
			    strcpy(tempname,a[i].name); 
			    first=0;                            //有效通话的次数记为0  
		}
	    if(strcmp(a[i+1].name,tempname)!=0){         //下一个是其他人了
	        if(tempmoney!=0){
			    printf("Total amount: $%.2f\n",tempmoney/100.0);    //输出所有的钱 
	       	    tempmoney=0;    //当前这个人的电话总共的钱记为0 
	        }
	        else tempmoney=0;
	    }
	    else if(a[i].flag==0&&a[i+1].flag==1){               //下一个不是其他人的情况下,相邻两个刚好是一次电话 
	        first++;
			if(first==1)  printf("%s %02d\n",a[i].name,a[i].data[0]);    //如果这是这个人的第一通电话(防止某人一通电话都没有却输出)  
	        time=0;                                   //每一次通话的时间置为0 
		    printf("%02d:%02d:%02d %02d:%02d:%02d",a[i].data[1],a[i].data[2],a[i].data[3],a[i+1].data[1],a[i+1].data[2],a[i+1].data[3]);
		    int nowmoney=cal(a[i],a[i+1]);
		    printf(" %d $%.2f\n",time,nowmoney/100.0);
		    tempmoney=nowmoney+tempmoney;
	    }
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值