关于PAT A1048 Find Coins 有一测试点没通过

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10^​5 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10^​5​​ , the total number of coins) and M (≤10^3
​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V1 and V​2 (separated by a space) such that V​1 +V2 =M and V1 ≤V2
​​ . If such a solution is not unique, output the one with the smallest V​1
​​ . If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

一般来说,有测试点没通过是忽略了以下情况:

  1. 3 12
    2 6 6
    这种情况,满足2a=m时是否考虑到。

  2. 上面这个我是考虑到了的,但是按照我的写法却忽略了如下情况:
    2 12
    1 6
    这种时候,按照我原来的写法就会把6当作答案输出,导致测试点1答案错误!!改正这种情况后就全通过了。

#include<stdio.h>
int main(){
	int n,m,temp;
	int harshtable[100010]={0}; 
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++){
		scanf("%d",&temp);
		harshtable[temp]++;
	}
	int flag=0;
	for(int i=1;i<m/2+1;i++){
		if(i+i==m&&harshtable[i]>=2){
			printf("%d %d",i,i);
			flag=1;
			break;
		}
		else if(harshtable[i]!=0&&i+i!=m){    //就是这里少了判断2*i=m的情况,只有一个m/2时上一个条件不满足跳到这个条件却满足导致错误
			if(harshtable[m-i]!=0){
				printf("%d %d",i,m-i);
				flag=1;
				break;
			}
		}
	}
	if(flag==0)
	printf("No Solution");
	return 0;

	
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值