安装weblogic 报错Unsupported major.minor version 51.0的解决过程

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_36501591/article/details/79972111

本人使用的环境是Myeclipse10.7+jdk1.6

1.找到安装目录里的Disk1\install\下的ng.cmd脚本-->运行-->执行时出现闪退现象,

2.双击运行闪退,没关系,我们可以通过命令行的方式运行jar文件,出现详细的报错信息,如图所示:


3.出现提示错误:Unsupported major.minor version 51.0

3.1原因分析

类似错误均属于Java版本问题,即JDK版本过低,只要选择相对应的JDK版本编译即可。
48,49,50、51、52是Java编译器内部的版本号:
Unsupported major.minor version 52.0 对应于 JDK1.8(JRE1.8)

Unsupported major.minor version 51.0 对应于 JDK1.7(JRE1.7)

Unsupported major.minor version 50.0 对应于 JDK1.6(JRE1.6)
Unsupported major.minor version 49.0 对应于 JDK1.5(JRE1.5)
Unsupported major.minor version 48.0 对应于 JDK1.4(JRE1.4)

检查发现我MyECLIPSE中使用的JDK为1.6,而weblogic使用的JDK为1.7两者不匹配,考虑由于重新安装高版本的weblogic比较麻烦,我选择尝试将Myeclipse中的JDK修改为1.7版本,解决过程如下:

重新安装jdk1.7的版本,并修改环境变量.

继续通过命令行的方式运行fmw_12.1.3.0.0_wls.jar文件,

报错不是有效的jdk

导致出现新的错:将下载的fmw_12.1.3.0.0_wls.jar移到了1.7的JDK的bin目录下,来运行安装。

使用上述安装方式:java -jar fmw_12.1.3.0.0_wls.jar,来启动安装。

第二种解决方案:直接双击.ng.cmd文件即可


运行成功


弹出安装页面,问题解决


参考资料:https://blog.csdn.net/dm1314oooooooo/article/details/70905415

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页