求二叉树的深度

求二叉树的深度

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T组数据。每组数据包括两个长度小于<font face="\"Times" new="" roman,="" serif\"="" style="box-sizing: border-box;">50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output
输出二叉树的深度。
Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
4
3
Hint
 
Author
 求二叉树深度,高度的三种算法:http://blog.csdn.net/qq_36525906/article/details/54973573

#include <bits/stdc++.h>

using namespace std;

struct Btree
{
    char data;
    struct Btree *lc,*rc;
};

char mid[10010];//中序序列
char las[10010];//后序序列

struct Btree* creat(int len, char *mid, char *las)//二叉树的重建
{
    struct Btree *root;
    int i ;
    if(len == 0)
    {
        return NULL;
    }
    root = new Btree;
    root -> data = las[len -1];//找到根节点(后序遍历的最后一位)
    for(i = 0; i < len; i++)//在中序序列中找到根节点的位置
    {
        if(mid[i] == las[len-1])
            break;
    }

    root -> lc = creat(i, mid, las);//递归遍历(左子树的长度,左子树在mid中开始位置的地址,左子树在las中开始位置的地址)
    root -> rc = creat(len-i-1, mid+i+1, las+i);//(右子树的长度,右子树在mid中开始位置的地址,右子树在las中开始位置的地址)

    return root;
};

int depth(struct Btree *root)//递归求树的深度
{
    if(root == NULL)
        return 0;
    else
    {
        int m = depth(root -> lc);
        int n = depth(root -> rc);
        return (m > n)?(m+1):(n+1);
    }
}

int main()
{
    int t;
    while(cin>>t)
    {
        while(t--)
        {
            cin>>mid>>las;
            int len = strlen(mid);
            struct Btree *root;
            root = creat(len,mid,las);
            int deep = depth(root);
            cout<<deep<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值