二叉排序树

二叉排序树

Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树
Input

开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)
Output

Example Input

2
123456789
987654321
432156789
0

Example Output

NO
NO
Hint

Author

PS:

二叉排序树,左孩子小于当前根节点,右孩子大于当前根节点,按照此顺序递归建树;验证两棵树是否相同,只需要让他们有序排列后看看是否相同,即可得证。

AC code:

#include<bits/stdc++.h>

using namespace std;

struct node
{
    char data;
    struct node *lc, *rc;
};

void creat(struct node *&root, char st)
{
    if(root==NULL)
    {
        root= new node;
        root->lc=NULL;
        root->rc=NULL;
        root->data= st;
    }
    else
    {

        if(st < root->data)
            creat(root->lc,st);
        else
            creat(root->rc,st);
    }
}

int i = 0;
char st2[100] = {0}, st3[100] = {0};
void qianxu(struct node * root)
{
    if(root)
    {
        st2[i++] = root->data;
        qianxu(root->lc);
        qianxu(root->rc);
    }
}

int j = 0;
void houxu(struct node * root)
{
    if(root)
    {
        houxu(root->lc);
        houxu(root->rc);
        st3[j++] = root->data;
    }
}

int main()
{
    int n;
    while(cin>>n)
    {
        if(n == 0) break;
        char st[100] = {0}, st1[100] = {0};
        struct node* root = NULL;
        cin>>st;
        int len = strlen(st);
        for(int i = 0; i < len; i++)
        {
            creat(root, st[i]);
        }
        qianxu(root);
        houxu(root);
        j = 0;
        i = 0;
        while(n--)
        {
            cin>>st1;
            if(strcmp(st1, st) == 0)
                cout<<"YES";
            else if(strcmp(st1, st2) == 0)
                cout<<"YES";
            else if(strcmp(st1, st3) == 0)
                cout<<"YES";
            else
                cout<<"NO";
            cout<<endl;
        }
        memset(st2,0,sizeof(st2));
        memset(st3,0,sizeof(st3));
    }
    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 156KB
Submit time: 2017-02-13 20:10:55
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值