zoj 1730

Crazy Tea Party

Time Limit: 2 Seconds       Memory Limit: 65536 KB

n participants of "crazy tea party" sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).

Input. The first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.

Output. For each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.


Sample Input

3
4
5
6


Sample Output

2
4

6


题意:是给你n个点形成环,顺序改逆序,每次相邻交换,求最少交换次数

分析:逆序数。公式很简单,推导有点麻烦。

            1.首先是关于相邻交换,最小的交换次数就是逆序数(相邻元素交换逆序数最多改变1) 

            2.根据 1,我们可知本题求救的就是把逆序环拆开后最小的逆序数 

            我们假设从 k点拆开,则串就是 k,...,1,n,...,k+1;

            则它的逆序数 为 k(k-1)/2 + (n-k)*(n-k-1)/2 整理后就可得到;

            当 k = n/2 时,式子有最小值(其实不整理也看得出来。。。); 

            3.结论 Min = L*(L-1)/2 + R*(R-1)/2 { L = n/2, R = n-L }。

#include <iostream>  
#include <cstdlib>  
  
using namespace std;  
  
int main()  
{  
    int n,m;  
    while ( cin >> n )  
    while ( n -- ) {  
        cin >> m;  
        int L = m/2;  
        int R = m-L;  
        cout << L*(L-1)/2 + R*(R-1)/2 << endl;  
    }  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值