2017乌鲁木齐网赛 B.Out-out-control cars

传送门

题意:

两个三角形,每个三角形有一个运动速度。问有没有可能他们在某个时间相交。

做法:

以一个三角形为静止,另一个三角形相对运动。那么这个三角形运动的路径,一定是在一条射线上,因为t>=0,

以t=0时的顶点开始,剩下的点全在一条线上运动,那么看这三条线是否跟静止的三角形是否有交点就好了。

细节:射线的处理:再选一个超范围的点。顶点相连这个线段可以为假想射线。

样例输入
3

0 1 2 1 1 3 1 0
9 2 10 4 8 4 -1 0

0 1 2 1 1 3 2 0
9 2 10 4 8 4 3 0

0 1 2 1 1 3 0 0
0 4 1 6 -1 6 1 -2
样例输出
Case #1: YES
Case #2: NO
Case #3: YES

//china no.1
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <vector>
#include <iostream>
#include <string>
#include <map>
#include <stack>
#include <cstring>
#include <queue>
#include <list>
#include <stdio.h>
#include <set>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <iomanip>
#include <cctype>
#include <sstream>
#include <functional>
#include <stdlib.h>
#include <time.h>
#include <bitset>
using namespace std;

#define pi acos(-1)
#define s_1(x) scanf("%d",&x)
#define s_2(x,y) scanf("%d%d",&x,&y)
#define s_3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define PI acos(-1)
#define endl '\n'
#define srand() srand(time(0));
#define me(x,y) memset(x,y,sizeof(x));
#define foreach(it,a) for(__typeof((a).begin()) it=(a).begin();it!=(a).end();it++)
#define close() ios::sync_with_stdio(0); cin.tie(0);
#define FOR(x,n,i) for(int i=x;i<=n;i++)
#define FOr(x,n,i) for(int i=x;i<n;i++)
#define fOR(n,x,i) for(int i=n;i>=x;i--)
#define fOr(n,x,i) for(int i=n;i>x;i--)
#define W while
#define sgn(x) ((x) < 0 ? -1 : (x) > 0)
#define bug printf("***********\n");
#define db double
#define ll long long
#define mp make_pair
#define pb push_back
typedef pair<long long int,long long int> ii;
typedef long long LL;
const int INF=0x3f3f3f3f;
const LL LINF=0x3f3f3f3f3f3f3f3fLL;
const int dx[]={-1,0,1,0,1,-1,-1,1};
const int dy[]={0,1,0,-1,-1,1,-1,1};
const int maxn=1e3+10;
const int maxx=600005;
const double EPS=1e-8;
const double eps=1e-8;
const int mod=1e9+7;
template<class T>inline T min(T a,T b,T c) { return min(min(a,b),c);}
template<class T>inline T max(T a,T b,T c) { return max(max(a,b),c);}
template<class T>inline T min(T a,T b,T c,T d) { return min(min(a,b),min(c,d));}
template<class T>inline T max(T a,T b,T c,T d) { return max(max(a,b),max(c,d));}
template <class T>
inline bool scan_d(T &ret){char c;int sgn;if (c = getchar(), c == EOF){return 0;}
while (c != '-' && (c < '0' || c > '9')){c = getchar();}sgn = (c == '-') ? -1 : 1;ret = (c == '-') ? 0 : (c - '0');
while (c = getchar(), c >= '0' && c <= '9'){ret = ret * 10 + (c - '0');}ret *= sgn;return 1;}

inline bool scan_lf(double &num){char in;double Dec=0.1;bool IsN=false,IsD=false;in=getchar();if(in==EOF) return false;
while(in!='-'&&in!='.'&&(in<'0'||in>'9'))in=getchar();if(in=='-'){IsN=true;num=0;}else if(in=='.'){IsD=true;num=0;}
else num=in-'0';if(!IsD){while(in=getchar(),in>='0'&&in<='9'){num*=10;num+=in-'0';}}
if(in!='.'){if(IsN) num=-num;return true;}else{while(in=getchar(),in>='0'&&in<='9'){num+=Dec*(in-'0');Dec*=0.1;}}
if(IsN) num=-num;return true;}

void Out(LL a){if(a < 0) { putchar('-'); a = -a; }if(a >= 10) Out(a / 10);putchar(a % 10 + '0');}
void print(LL a){ Out(a),puts("");}
//freopen( "in.txt" , "r" , stdin );
//freopen( "data.txt" , "w" , stdout );
//cerr << "run time is " << clock() << endl;

db xx[88],yy[88];
db d1,d2;

int F;
int t;
int dcmp(double x)
{
    if(fabs(x) < EPS) return 0;
    else return x < 0 ? -1 : 1;
}

struct Point
{
    double x, y;
    Point(const Point& rhs): x(rhs.x), y(rhs.y) { } //拷贝构造函数
    Point(double x = 0, double y = 0) : x(x), y(y) { }
    inline void input()
    {
        scanf("%lf%lf",&x,&y);
    }
    inline void print()
    {
        printf("%.6lf %.6lf\n",x,y);
    }
     Point operator + (const Point &b)const
    {
        return Point(x+b.x,y+b.y);
    }
    Point operator - (const Point &b)const
    {
        return Point(x-b.x,y-b.y);
    }
};

typedef Point Vector;

Vector operator + (Vector A, Vector B) { return Vector(A.x + B.x, A.y + B.y); }
Vector operator - (Vector A, Vector B) { return Vector(A.x - B.x, A.y - B.y); }
Vector operator * (Vector A, double p) { return Vector(A.x * p, A.y * p); }
Vector operator / (Vector A, double p) { return Vector(A.x / p, A.y / p); }

double Cross(Point a,Point b)
{
    return a.x*b.y - a.y*b.x;
}

//向量点积
double Dot(Vector A, Vector B) { return A.x*B.x + A.y*B.y; }

//线段相交判定,交点不在一条线段的端点
int SegmentProperIntersection(Point a1, Point a2, Point b1, Point b2)
{
    double c1 = Cross(a2-a1, b1-a1), c2 = Cross(a2-a1, b2-a1);
    double c3 = Cross(b2-b1, a1-b1), c4 = Cross(b2-b1, a2-b1);
    return dcmp(c1)*dcmp(c2) <=0 && dcmp(c3)*dcmp(c4) <=0;
}

Point a[5],b[5],c[5];
int main()
{
    //freopen( "in.txt" , "r" , stdin );
    cin>>t;
    for(int cas=1;cas<=t;cas++)
    {
        F=0;
        db x1,x2,y1,y2;
        a[0].input();b[0].input();c[0].input();
        scanf("%lf %lf",&x1,&y1);
        a[1].input();b[1].input();c[1].input();
        scanf("%lf %lf",&x2,&y2);
        d1=x2-x1,d2=y2-y1;
        d1*=1e10,d2*=1e10;
        a[2].x=a[1].x+d1;
        a[2].y=a[1].y+d2;
        b[2].x=b[1].x+d1;
        b[2].y=b[1].y+d2;
        c[2].x=c[1].x+d1;
        c[2].y=c[1].y+d2;
        if(SegmentProperIntersection(a[1],a[2],a[0],b[0]))
            F=1;
        if(SegmentProperIntersection(a[1],a[2],a[0],c[0]))
            F=1;
        if(SegmentProperIntersection(a[1],a[2],b[0],c[0]))
            F=1;
        if(SegmentProperIntersection(b[1],b[2],a[0],b[0]))
            F=1;
        if(SegmentProperIntersection(b[1],b[2],a[0],c[0]))
            F=1;
        if(SegmentProperIntersection(b[1],b[2],b[0],c[0]))
            F=1;
        if(SegmentProperIntersection(c[1],c[2],a[0],b[0]))
            F=1;
        if(SegmentProperIntersection(c[1],c[2],a[0],c[0]))
            F=1;
        if(SegmentProperIntersection(c[1],c[2],b[0],c[0]))
            F=1;
        printf("Case #%d: ",cas);
        if(F)
        {
            puts("YES");
        }
        else puts("NO");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值