1010 一元多项式求导 (25 point(s))

设计函数求一元多项式的导数。(注:x​n​​(n为整数)的一阶导数为nx​n−1​​。)

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过 1000 的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是 0,但是表示为 0 0

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

链表

#include<stdio.h>
#include<stdlib.h>
typedef struct Node* List;
struct Node{
	int coef;
	int e;
	List Next;
};
int main(){
	List head=(List)malloc(sizeof(struct Node));
	scanf("%d%d",&head->coef,&head->e);
	List t=head;
	if(head->e==0)printf("0 0");
	else{
		while(1){
		List p=(List)malloc(sizeof(struct Node));
		scanf("%d%d",&p->coef, &p->e);
		if(p->e!=0){
    			t->Next=p;
			t=p;
		}else{
			t->Next=NULL;
			free(p);
			break;
		}
	}
	for(; head!=NULL; head=head->Next){
		printf("%d %d",head->coef*head->e, head->e-1);
		if(head->Next)printf(" ");
	}     
	}                                                                                            
	return 0;
}	 

直接求导

注意“零多项式”的指数和系数都是 0,但是表示为 0 0

#include<cstdio>
int main(){
	int e, coef, flag=0;
	while(scanf("%d%d", &coef, &e)!=EOF){
		if(coef && e){
			if(flag)printf(" ");
			printf("%d %d", coef*e, e-1);
			flag=1;
		}
	}
	if(flag==0)printf("0 0");
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值