ZOJ Problem Set - 3418 Binary Number



Binary Number

Time Limit: 2 Seconds       Memory Limit: 65536 KB

For 2 non-negative integers x and y, f(xy) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1, f(0, 3)=2, f(5, 10)=4.

Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(ab) is minimized. If there are more than one such integers in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < mn ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output

1
2
1
1
1
9999
0

题意:给你m个数,和n个数,求出这n个数,每个数的二进制数与这m个数的二进制数相差位数最少的数,存在多个数相差位数相同时取最小的

题解:暴力,二进制运算,疑惑一下剩下的1的个数就是不同位的个数

代码:


#include <bits/stdc++.h>
using namespace std;
int m, n;
int x[110], y[110];
int mini;
int minp;
int main()
{
	int T;
	cin >> T;
	while (T--)
	{
		cin >> m >> n;
		for (int i = 0; i<m; i++)
		{
			cin >> x[i];
		}
		for (int i = 0; i<n; i++)
		{
			cin >> y[i];
		}
		for (int i = 0; i<n; i++)
		{
			mini = 0;
			minp = 1000;
			for (int j = 0; j<m; j++)
			{
				int p = 0;
				int t = y[i] ^ x[j];
				while (t>0)
				{
					if (t & 1)
					{
						p++;
					}
					t = t >> 1;
				}
				if (p < minp)
				{
					minp = p;
					mini = x[j];
				}
				else if(p == minp)
				{
					if (x[j] < mini)
						mini = x[j];
				}

			}
			cout << mini << endl;
		}
	}
}


Binary Number

Time Limit: 2 Seconds       Memory Limit: 65536 KB

For 2 non-negative integers x and y, f(xy) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1, f(0, 3)=2, f(5, 10)=4.

Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(ab) is minimized. If there are more than one such integers in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < mn ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output

1
2
1
1
1
9999
0
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值