HDU-5211 (aF(i) mod ai = 0)

WLD likes playing with a sequence a[1..N] . One day he is playing with a sequence of N integers. For every index i, WLD wants to find the smallest index F(i) ( if exists ), that i<F(i)n , and aF(i) mod ai = 0. If there is no such an index F(i) , we set F(i)
as 0.
Input
There are Multiple Cases.(At MOST 10 )

For each case:

The first line contains one integers N(1N10000) .

The second line contains N integers a1,a2,...,aN(1ai10000)
,denoting the sequence WLD plays with. You can assume that all ai is distinct.
Output
For each case:

Print one integer.It denotes the sum of all F(i)
for all 1i<n

Sample Input
4
1 3 2 4
Sample Output
6


        
  
Hint
   
   
F(1)=2 F(2)=0 F(3)=4 F(4)=0





aF(i) mod ai = 0是关键,思路:从这个数开始向后找它的公倍数,如果是它的公倍数,总数加上公倍数的下表,就是第几个数,如果没有这个数的公倍数,就加0;


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[10010];
main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int sum=0;
        memset(a,0,sizeof(a));
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n-1;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if(a[j]%a[i]==0)
                {
                    sum+=j;
                    break;
                }
            }
        }
        printf("%d\n",sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值