HDOJ-1004 Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

统计出现次数最多的字符串然后输出,用冒泡的方法将相同字符串出现的次数统计到一个数组,然后记住出现次数最多位置,将这个位置的字符串输出。

//AC: 15MS  1692K
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    int N;
    while(scanf("%d",&N)!=EOF){
        char color[1005][20];
        int max=0,t=0,num[1005];
        if(N==0)
            break;
        for(int i=0;i<N;i++){
            scanf("%s",color[i]);
        }
        memset(num,0,sizeof(num));
        for(int i=1;i<N;i++)
            for(int j=0;j<i-1;j++)
                if(strcmp(color[i],color[j])==0)
                    num[i]++;
        for(int i=1;i<N;i++){
            if(max<num[i]){
                max=num[i];
                t=i;
            }
        }
        printf("%s\n",color[t]);
    }
    return 0;
}

开始还准备用map< string,int >来写,结果自己完全没理解map,满脑子骚操作。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值