hdu4738

Caocao’s Bridges

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5560 Accepted Submission(s): 1745

Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.

Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0

Sample Output
-1
4

难点就是如何处理重边;
这里我们可以根据父子关系来处理,即如果v有两条父子边直接与u相连,则这一个一定不是桥,把其中一条边也带入搜索即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=2000;
const int maxm=1100000;
int dfn[maxn],low[maxn],stack[maxn],instack[maxn],cost[maxn];
int head[maxm],cnt,top,index,bridge;
struct node
{
    int v,next,w;
}edge[maxm];
void init()
{
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(cost,0,sizeof(cost));
    cnt=0,top=0,index=0,bridge=0;
}
void add_edge(int u,int v,int w)
{
    edge[cnt].v=v;
    edge[cnt].next=head[u];
//  printf("head[u]:%d\n",head[u]);
    edge[cnt].w=w;
    head[u]=cnt++;
}
void tarjan(int u,int pre)
{
    dfn[u]=low[u]=++index;
    int v;
    int pre_num=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].v;
    //  printf("edge:%d\n",v);
        if(v==pre&&!pre_num)
        {
            pre_num++;
            continue;
        }

        if(!dfn[v])
        {
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
            {
                {
                    cost[bridge]=edge[i].w;
                    bridge++;
                }       
            }
        }
        else
        {
            low[u]=min(low[u],dfn[v]);
        }
    }
}
int main ()
{
    int n,m;
    while(cin>>n>>m)
    {
        if(m==0&&n==0)
            break;
        init();
    for(int i=1;i<=m;i++)
    {
        int xx,yy,zz;
        scanf("%d%d%d",&xx,&yy,&zz);
        add_edge(xx,yy,zz);
        add_edge(yy,xx,zz);
    }
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        if(!dfn[i])
        {
        //  printf(":::%d\n",i);
            tarjan(i,i);
            ans++;
        }
    }
    if(ans>1)
    {
        printf("0\n");
    }
    else
    {
        if(bridge==0)
        {
            printf("-1\n");
        }
        else
        {
            int res=0x3f3f3f3f;
            for(int i=0;i<bridge;i++)
            {
                if(cost[i]<res)
                {
                    res=cost[i];
                }
            }
            if(res==0)
            {
                printf("1\n");
            }
            else
            {
                printf("%d\n",res);
            }
        }
    }
}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值