[kuangbin带你飞]专题九 连通图 求割点裸题

B - Network UVA - 315
A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting
several places numbered by integers from 1 to N. No two places have the same number. The lines
are bidirectional and always connect together two places and in each place the lines end in a telephone
exchange. There is one telephone exchange in each place. From each place it is possible to reach
through lines every other place, however it need not be a direct connection, it can go through several
exchanges. From time to time the power supply fails at a place and then the exchange does not operate.
The officials from TLC realized that in such a case it can happen that besides the fact that the place
with the failure is unreachable, this can also cause that some other places cannot connect to each other.
In such a case we will say the place (where the failure occured) is critical. Now the officials are trying
to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line
of each block there is the number of places N < 100. Each of the next at most N lines contains the
number of a place followed by the numbers of some places to which there is a direct line from this place.
These at most N lines completely describe the network, i.e., each direct connection of two places in
the network is contained at least in one row. All numbers in one line are separated by one space. Each
block ends with a line containing just ‘0’. The last block has only one line with N = 0.
Output
The output contains for each block except the last in the input file one line containing the number of
critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1
2

题意:
求这个无向图的割点个数。
裸题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=200000;
int head[maxn],cnt=0;
struct node
{
	int v,next;
}edge[maxn];
int n;
void add_edge(int u,int v)
{
	edge[cnt].v=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
int low[maxn],dfn[maxn],stack[maxn],instack[maxn],cut[maxn];
int indexx;
void init()
{
	cnt=0;
	indexx=0;
	memset(head,-1,sizeof(head));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(instack,0,sizeof(instack));
	memset(cut,0,sizeof(cut));
}
void tarjan(int u,int pre)
{
	low[u]=dfn[u]=++indexx;
	instack[u]=0;
	int son=0;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].v;
		if(v==pre)
			continue;
		if(!dfn[v])
		{
			son++;
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
			if(u!=pre&&low[v]>=dfn[u])
			{
				cut[u]=1;
			}
		}
		else
		{
			low[u]=min(low[u],dfn[v]);
		}
	}
	if(u==pre&&son>1)
		cut[u]=1;
}
void solve()
{
	for(int i=1;i<=n;i++)
	{
		if(!dfn[i])
		{
			tarjan(i,i);
		}
	}
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		if(cut[i])
		{
			ans++;
		}
	}
	printf("%d\n",ans);
}
int main ()
{
	while(~scanf("%d",&n))
	{
		if(n==0)
		{
			break;
		}
		int xx;
		init();
		while(~scanf("%d",&xx))
		{
			if(xx==0)
			{
				break;
			}
			int yy;
			char ch;
			while(~scanf("%d%c",&yy,&ch))
			{
				add_edge(xx,yy);
				add_edge(yy,xx);
				if(ch=='\n')
				{
					break;
				}
			}
		}
		solve();
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值