作业训练一编程题4. 字符串反转3

【问题描述】

       给出一个字符串,请将其每个单词反转后输出。

【输入形式】

      输入第一行为一个正整数N,表示测试用例数,接下来的N行,每行一个字符串。

【输出形式】

      输出N行,每行对应一个反转后的字符串。

【样例输入】

3
olleh !dlrow
m'I morf .unh
I ekil .tae

【样例输出】

hello world!
I'm from hnu.
I like eat.

【思路分析】

对于结束符的判断,在while循环条件中加入stream>>word即可。其底层,stream读取到EOF时返回空stream,while判断为空终止循环。

#include <iostream>
#include <algorithm>
#include <sstream>

using namespace std;

int main() {
    int n;
    string words,word;
    stringstream ss;
    cin>>n;
    cin.get();
    while (n--){
        getline(cin,words);
        ss<<words;
        ss>>word;
        reverse(word.begin(), word.end());
        cout<<word;
        while (ss>>word) {
            reverse(word.begin(), word.end());
            cout <<" "<< word;
        }
        cout<<endl;
        ss.sync();
        ss.clear();
    }
    return 0;

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值