4-2 顺序表操作集 (20分) PTA

本题要求实现顺序表的操作集。

函数接口定义:

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

其中List结构定义如下:

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

各个操作函数的定义为:

List MakeEmpty():创建并返回一个空的线性表;

Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;

bool Insert( List L, ElementType X, Position P ):将X插入在位置P并返回true。若空间已满,则打印“FULL”并返回false;如果参数P指向非法位置,则打印“ILLEGAL POSITION”并返回false;

bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“POSITION P EMPTY”(其中P是参数值)并返回false。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 5
#define ERROR -1
typedef enum {false, true} bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

int main()
{
    List L;
    ElementType X;
    Position P;
    int N;

    L = MakeEmpty();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        if ( Insert(L, X, 0)==false )
            printf(" Insertion Error: %d is not in.\n", X);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        P = Find(L, X);
        if ( P == ERROR )
            printf("Finding Error: %d is not in.\n", X);
        else
            printf("%d is at position %d.\n", X, P);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &P);
        if ( Delete(L, P)==false )
            printf(" Deletion Error.\n");
        if ( Insert(L, 0, P)==false )
            printf(" Insertion Error: 0 is not in.\n");
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

6
1 2 3 4 5 6
3
6 5 1
2
-1 6

输出样例:

FULL Insertion Error: 6 is not in.
Finding Error: 6 is not in.
5 is at position 0.
1 is at position 4.
POSITION -1 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.
POSITION 6 EMPTY Deletion Error.

FULL Insertion Error: 0 is not in.

#include <stdio.h> #include <stdlib.h> #define MAXSIZE 5 #define ERROR -1 //typedef enum {false , true} bool; typedef int ElementType; typedef int Position; typedef struct LNode *List; struct LNode {     ElementType Data[MAXSIZE];     Position Last; /* 保存线性表中最后一个元素的位置 */ }; List MakeEmpty();  Position Find( List L, ElementType X ); bool Insert( List L, ElementType X, Position P ); bool Delete( List L, Position P ); int main() {     List L;     ElementType X;     Position P;     int N;     L = MakeEmpty();     scanf("%d", &N);     while ( N-- ) {         scanf("%d", &X);         if ( Insert(L, X, 0)==false )             printf(" Insertion Error: %d is not in.\n", X);     }     scanf("%d", &N);     while ( N-- ) {         scanf("%d", &X);         P = Find(L, X);         if ( P == ERROR )             printf("Finding Error: %d is not in.\n", X);         else             printf("%d is at position %d.\n", X, P);     }     scanf("%d", &N);     while ( N-- ) {         scanf("%d", &P);         if ( Delete(L, P)==false )             printf(" Deletion Error.\n");         if ( Insert(L, 0, P)==false )             printf(" Insertion Error: 0 is not in.\n");     }     return 0; } List MakeEmpty() { List Ptrl; Ptrl = (List)malloc(sizeof(struct LNode)); Ptrl->Last = -1; return Ptrl;  }   Position Find(List L,ElementType X)  {   int i = 0;     while(i<=L->Last&&L->Data[i] != X)   i++;   if(i>L->Last) return ERROR;   else return i;  }  bool Insert(List L,ElementType X,Position P)  {   if(L->Last == MAXSIZE - 1){   printf("FULL");   return false; } else if(P<0||P>(L->Last+1)){               //可以插入到最后  printf("ILLEGAL POSITION"); return false; } else { int i; for(i = L->Last ;i>=P;i--){ L->Data[i+1] = L->Data[i]; } L->Data[P] = X; ++L->Last; return true; }    }  bool Delete(List L,Position P)  {   if(P<1||P>L->Last)   printf("POSITION %d EMPTY",P);   else {   int i;   for(i = P;i<=L->Last;i++){   L->Data[i] = L->Data[i+1]; } L->Last--; return true; }    }

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值