POJ2533 最长上升子序列(LIS)动态规划经典DP

问题链接:http://poj.org/problem?id=2533

最长上升子序列longest  increasing subsequence

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

动态规划

    设数组a,Maxlen;

    a为输入的序列

    Maxlen[k](1<k<n)为以a[k]结束的最长上升子序列的长度(也就是a[0]a[1]a[2]......a[k])

    求解以a[n]为终点的序列(a[0],a[1],a[2].....a[n-1],a[n]) 的最长上升子序列的长度,我们可以把他a(n),与a[n-1],a[n-2].......a[2],a[1],a[0]进行比较,如果如果a[n]大于a[n-1],a[n-2].......a[2],a[1],a[0]中的任何一个数,那么Maxlen[n] = Maxlen[k] +1 (1<k<n),求出最大的数,就是以a[n]为终点的LIS。

        由此得到状态转移方程:

                              Maxlen(1) = 1;

                              Maxlen(k) = max(Maxlen(i) (1 < i < k && a(i) < a(k) && k!= 1)  ) +1

           这个状态方程的意思是 Maxlen(k)的值就是在 a(k)左边,“终点”数值小于a(k) 且 长度最长的那个lis的长度+1.

结合图和代码会好理解很多

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cctype>
#include<cstring>
using namespace std;
const int Max = 1000;
int main(){
	int i,j,n;
	int a[Max+10];//输入的序列 
	int Maxlen[Max+10];//以ai结尾的上升序列的最大长度 
	memset(Maxlen,0,1000);
	cin >> n;
    Maxlen[0] = 1;
	for(i = 0; i < n; i++){
		cin >> a[i];
	}
	for(i = 1; i < n; i++){
		for(j = 0; j < i; j++){
			if(a[i] > a[j] && Maxlen[i] < Maxlen[j]+1){
				Maxlen[i] = Maxlen[j]+1;
			}
		}
	}
	sort(Maxlen,Maxlen+1);//排序 
	cout<<Maxlen[n-1];
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值