1037 Magic Coupon (22/25 分)C语言——qsort()

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

分析

Coupons 优惠券

bonus n. 奖金;红利;额外津贴

at most 至多

最大正数相乘,最大负数相乘  关键:排序

冒泡排序:第四个测试点运行超时(C++有自带sort()函数好像会好一点)

后面尝试C自带qsort(),ok

C库stdlib自带排序函数qsort()

备注:cmp函数中a-b是从小到大排序;b-a是从大到小

代码1(没过)

#include<stdio.h>
#define Max 110000
int cou[Max],pro[Max];
void bubble(int*,int);
int main(){
	int NC,NP;
	int i,j,sum=0;
	scanf("%d",&NC);
	for(i=1;i<=NC;i++) scanf("%d",&cou[i]);
	scanf("%d",&NP);
	for(i=1;i<=NP;i++) scanf("%d",&pro[i]);
	//bubble sort: from max to min 
	bubble(cou,NC);
	bubble(pro,NP);
	i=1;j=1;
	while( cou[i]>0 && pro[j]>0 ) sum+=cou[i++]*pro[j++];
	i=0;j=0;
	while( cou[NC-i]<0 && pro[NP-j]<0 ) sum+=cou[NC-i++]*pro[NP-j++];
	//ouput
	printf("%d",sum);
}
//bubble sort: from max to min 
void bubble(int *p,int n){
	int i,j,temp;
	for(i=1;i<=n;i++){
		p[0]=p[i];
		for(j=i+1;j<=n;j++)
			if(p[j]>p[i]) {
					temp=p[j];
					p[j]=p[i];
					p[i]=temp;
			}
	}
}

代码2(过)

#include<stdio.h>
#include<stdlib.h>
#define Max 110000
int cou[Max],pro[Max];
int cmp(const int *a, const int *b){
	//from max to min
	return (*(int*)b-*(int*)a);
}
int main(){
	int NC,NP;
	int i,j,sum=0;
	scanf("%d",&NC);
	for(i=0;i<NC;i++) scanf("%d",&cou[i]);
	scanf("%d",&NP);
	for(i=0;i<NP;i++) scanf("%d",&pro[i]);
	//sort: from max to min 
	qsort(cou,NC,sizeof(int),cmp);
	qsort(pro,NC,sizeof(int),cmp);
	//for(i=0;i<NC;i++) printf("%d",cou[i]);printf("\n");//delete
	//for(i=0;i<NP;i++) printf("%d",pro[i]);printf("\n");//delete
	i=j=0;
	while( cou[i]>0 && pro[j]>0 ) sum+=cou[i++]*pro[j++];
	i=j=1;
	while( cou[NC-i]<0 && pro[NP-j]<0 ) sum+=cou[NC-i++]*pro[NP-j++];
	//ouput
	printf("%d",sum);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值