1054 The Dominant Color (20 分)C语言

1054 The Dominant Color (20 分)

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2^{24}). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

分析

pixel 像素

proportion 比例

resolution 分辨率 常用:解决

 

代码

#include<stdio.h>
#define MAX 20000000
int color[MAX]={0},set[MAX],num=0;
/// color store number of same color
/// set store different color id
///num store number of different color
int main(){
    int M,N;
    int i,j,c;
    scanf("%d %d",&M,&N);
    for(i=0;i<N;i++)
        for(j=0;j<M;j++){
            scanf("%d",&c);
            if(!color[c]) set[num++]=c;
            color[c]++;
        }
    /// find max
    c=0;
    for(i=1;i<num;i++)
        if(color[ set[i] ]>color[ set[c] ]) c=i;
    printf("%d",set[c]);
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值